summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-04-07 06:17:46 +0000
committerHans de Graaff <graaff@gentoo.org>2012-04-07 06:17:46 +0000
commita5ec991af8146bd8974cb599168a17a83b94a15d (patch)
treec2f4397227793ca1fe889c6a51bb107a4c713b39 /dev-ruby/addressable
parentmarked x86 per bug 410937 (diff)
downloadgentoo-2-a5ec991af8146bd8974cb599168a17a83b94a15d.tar.gz
gentoo-2-a5ec991af8146bd8974cb599168a17a83b94a15d.tar.bz2
gentoo-2-a5ec991af8146bd8974cb599168a17a83b94a15d.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/addressable')
-rw-r--r--dev-ruby/addressable/ChangeLog9
-rw-r--r--dev-ruby/addressable/addressable-2.2.7.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/dev-ruby/addressable/ChangeLog b/dev-ruby/addressable/ChangeLog
index c333499a5e94..d807cb671c89 100644
--- a/dev-ruby/addressable/ChangeLog
+++ b/dev-ruby/addressable/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/addressable
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/addressable/ChangeLog,v 1.19 2011/09/19 18:33:51 graaff Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/addressable/ChangeLog,v 1.20 2012/04/07 06:17:46 graaff Exp $
+
+*addressable-2.2.7 (07 Apr 2012)
+
+ 07 Apr 2012; Hans de Graaff <graaff@gentoo.org> +addressable-2.2.7.ebuild:
+ Version bump.
19 Sep 2011; Hans de Graaff <graaff@gentoo.org> addressable-2.2.6.ebuild:
Frob build system so that we don't need rspec just to build the
diff --git a/dev-ruby/addressable/addressable-2.2.7.ebuild b/dev-ruby/addressable/addressable-2.2.7.ebuild
new file mode 100644
index 000000000000..51f8875793e9
--- /dev/null
+++ b/dev-ruby/addressable/addressable-2.2.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/addressable/addressable-2.2.7.ebuild,v 1.1 2012/04/07 06:17:46 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 jruby ree18"
+
+RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
+RUBY_FAKEGEM_TASK_TEST="spec:normal"
+
+RAKE_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A replacement for the URI implementation that is part of Ruby's standard library."
+HOMEPAGE="http://addressable.rubyforge.org/"
+
+LICENSE="as-is"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:0 )"
+
+all_ruby_prepare() {
+ # Remove spec-related tasks so that we don't need to require rspec
+ # just to build the documentation, bug 383611.
+ sed -i -e '/spectask/d' Rakefile || die
+ rm tasks/spec.rake || die
+
+ # Skip fragile test broken with random hash ordering in ruby
+ # https://github.com/sporkmonger/addressable/issues/60
+ sed -i -e '4287,4291 s:^:#:' spec/addressable/uri_spec.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -I lib -S spec spec || die "Tests failed."
+}