summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-14 20:44:54 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-14 20:44:54 +0000
commitf54f39927c48fed96d33a48fdb5a51977ce5baa9 (patch)
tree17dd0225686bcb57d38f80792564a48cd0103a3c /dev-ruby/annoy
parentenable-test ./configure option only enables build of extra programs, so no ne... (diff)
downloadgentoo-2-f54f39927c48fed96d33a48fdb5a51977ce5baa9.tar.gz
gentoo-2-f54f39927c48fed96d33a48fdb5a51977ce5baa9.tar.bz2
gentoo-2-f54f39927c48fed96d33a48fdb5a51977ce5baa9.zip
Initial import of annoy, needed for Rudy.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/annoy')
-rw-r--r--dev-ruby/annoy/ChangeLog10
-rw-r--r--dev-ruby/annoy/annoy-0.5.5.ebuild32
-rw-r--r--dev-ruby/annoy/files/annoy-0.5.5-hanna.patch40
-rw-r--r--dev-ruby/annoy/metadata.xml5
4 files changed, 87 insertions, 0 deletions
diff --git a/dev-ruby/annoy/ChangeLog b/dev-ruby/annoy/ChangeLog
new file mode 100644
index 000000000000..ea23e6b38ed7
--- /dev/null
+++ b/dev-ruby/annoy/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/annoy
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/annoy/ChangeLog,v 1.1 2010/02/14 20:44:52 flameeyes Exp $
+
+*annoy-0.5.5 (14 Feb 2010)
+
+ 14 Feb 2010; Diego E. Pettenò <flameeyes@gentoo.org> +annoy-0.5.5.ebuild,
+ +files/annoy-0.5.5-hanna.patch, +metadata.xml:
+ Initial import of annoy, needed for Rudy.
+
diff --git a/dev-ruby/annoy/annoy-0.5.5.ebuild b/dev-ruby/annoy/annoy-0.5.5.ebuild
new file mode 100644
index 000000000000..fc6bde0c5ec0
--- /dev/null
+++ b/dev-ruby/annoy/annoy-0.5.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/annoy/annoy-0.5.5.ebuild,v 1.1 2010/02/14 20:44:52 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RESTRICT=test
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Like your annoying friend that asks you questions all the time"
+HOMEPAGE="http://solutious.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend '>=dev-ruby/highline-1.5.0'
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${P}-hanna.patch
+}
diff --git a/dev-ruby/annoy/files/annoy-0.5.5-hanna.patch b/dev-ruby/annoy/files/annoy-0.5.5-hanna.patch
new file mode 100644
index 000000000000..eaff019208ae
--- /dev/null
+++ b/dev-ruby/annoy/files/annoy-0.5.5-hanna.patch
@@ -0,0 +1,40 @@
+From 4ab673e77653d2342556c1c7495cbeac59887557 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Diego=20Elio=20'Flameeyes'=20Petten=C3=B2?= <flameeyes@gmail.com>
+Date: Sun, 14 Feb 2010 21:22:30 +0100
+Subject: [PATCH] Don't force Hanna usage for documentation building.
+
+Since Hanna is not always available (and requires a specific version of
+RDoc gem), don't force to use it with no alternative. Instead, if not
+available, fallback to the standard rdoc support within rake.
+---
+ Rakefile | 7 ++++++-
+ 1 files changed, 6 insertions(+), 1 deletions(-)
+
+diff --git a/Rakefile b/Rakefile
+index 85d1c50..d1a2721 100644
+--- a/Rakefile
++++ b/Rakefile
+@@ -1,7 +1,6 @@
+ require 'rubygems'
+ require 'rake/clean'
+ require 'rake/gempackagetask'
+-require 'hanna/rdoctask'
+ require 'fileutils'
+ include FileUtils
+
+@@ -66,6 +65,12 @@ end
+
+ # RUBY DOCS TASK ==================================
+
++begin
++ require 'hanna/rdoctask'
++rescue LoadError
++ require 'rake/rdoctask'
++end
++
+ Rake::RDocTask.new do |t|
+ t.rdoc_dir = 'doc'
+ t.title = @spec.summary
+--
+1.7.0
+
diff --git a/dev-ruby/annoy/metadata.xml b/dev-ruby/annoy/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/annoy/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>