summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Wilmott <p8952@gentoo.org>2014-05-08 20:58:59 +0000
committerPeter Wilmott <p8952@gentoo.org>2014-05-08 20:58:59 +0000
commitc1cc79ee8bf364979f45f9d8b2a7d2fe682885b5 (patch)
treec315c30a2eea9706c0943c9e2d20cac0da895827 /dev-ruby/ascii85
parentRemove unused patch. (diff)
downloadgentoo-2-c1cc79ee8bf364979f45f9d8b2a7d2fe682885b5.tar.gz
gentoo-2-c1cc79ee8bf364979f45f9d8b2a7d2fe682885b5.tar.bz2
gentoo-2-c1cc79ee8bf364979f45f9d8b2a7d2fe682885b5.zip
Drop ruby18 target, add ruby21 target.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-ruby/ascii85')
-rw-r--r--dev-ruby/ascii85/ChangeLog9
-rw-r--r--dev-ruby/ascii85/ascii85-1.0.2-r2.ebuild29
2 files changed, 36 insertions, 2 deletions
diff --git a/dev-ruby/ascii85/ChangeLog b/dev-ruby/ascii85/ChangeLog
index 8c6373434ba5..5199395ccd06 100644
--- a/dev-ruby/ascii85/ChangeLog
+++ b/dev-ruby/ascii85/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ascii85
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ascii85/ChangeLog,v 1.20 2013/11/02 19:35:37 mrueg Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ascii85/ChangeLog,v 1.21 2014/05/08 20:58:59 p8952 Exp $
+
+*ascii85-1.0.2-r2 (08 May 2014)
+
+ 08 May 2014; Peter Wilmott <p8952@gentoo.org> +ascii85-1.0.2-r2.ebuild:
+ Drop ruby18 target, add ruby21 target.
02 Nov 2013; Manuel Rüger <mrueg@gentoo.org> -ascii85-1.0.2.ebuild:
Cleanup old.
diff --git a/dev-ruby/ascii85/ascii85-1.0.2-r2.ebuild b/dev-ruby/ascii85/ascii85-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..c905d4005115
--- /dev/null
+++ b/dev-ruby/ascii85/ascii85-1.0.2-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ascii85/ascii85-1.0.2-r2.ebuild,v 1.1 2014/05/08 20:58:59 p8952 Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.txt"
+
+RUBY_FAKEGEM_NAME="Ascii85"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Methods for encoding/decoding Adobe's binary-to-text encoding of the same name."
+HOMEPAGE="http://ascii85.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+}