summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-10-02 01:29:04 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-10-02 01:29:04 +0000
commit135868982b259d11f62cc8a9972158a8f02cb2b0 (patch)
treecb188372ed4ba92a5c5b67975ff6a385a17b9cb3 /dev-ruby/aws-sdk
parentstable ppc, bug #436324 (diff)
downloadgentoo-2-135868982b259d11f62cc8a9972158a8f02cb2b0.tar.gz
gentoo-2-135868982b259d11f62cc8a9972158a8f02cb2b0.tar.bz2
gentoo-2-135868982b259d11f62cc8a9972158a8f02cb2b0.zip
Version bump (finally) with a patch to support Ruby 1.8 syntax for a while still.
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/aws-sdk')
-rw-r--r--dev-ruby/aws-sdk/ChangeLog9
-rw-r--r--dev-ruby/aws-sdk/aws-sdk-1.6.7.ebuild60
-rw-r--r--dev-ruby/aws-sdk/files/aws-sdk-1.6.7.patch45
3 files changed, 113 insertions, 1 deletions
diff --git a/dev-ruby/aws-sdk/ChangeLog b/dev-ruby/aws-sdk/ChangeLog
index e22037afd071..587473de4d35 100644
--- a/dev-ruby/aws-sdk/ChangeLog
+++ b/dev-ruby/aws-sdk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/aws-sdk
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/aws-sdk/ChangeLog,v 1.10 2012/08/10 15:40:58 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/aws-sdk/ChangeLog,v 1.11 2012/10/02 01:29:04 flameeyes Exp $
+
+*aws-sdk-1.6.7 (02 Oct 2012)
+
+ 02 Oct 2012; Diego E. Pettenò <flameeyes@gentoo.org> +aws-sdk-1.6.7.ebuild,
+ +files/aws-sdk-1.6.7.patch:
+ Version bump (finally) with a patch to support Ruby 1.8 syntax for a while
+ still.
*aws-sdk-1.6.3 (10 Aug 2012)
diff --git a/dev-ruby/aws-sdk/aws-sdk-1.6.7.ebuild b/dev-ruby/aws-sdk/aws-sdk-1.6.7.ebuild
new file mode 100644
index 000000000000..c297756b13a8
--- /dev/null
+++ b/dev-ruby/aws-sdk/aws-sdk-1.6.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/aws-sdk/aws-sdk-1.6.7.ebuild,v 1.1 2012/10/02 01:29:04 flameeyes Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="ca-bundle.crt"
+
+GITHUB_USER="amazonwebservices"
+GITHUB_PROJECT="${PN}-for-ruby"
+RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
+
+RUBY_FAKEGEM_GEMSPEC="${T}/${P}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Official SDK for Amazon Web Services"
+HOMEPAGE="http://aws.amazon.com/sdkforruby"
+SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/tarball/${PV} -> ${GITHUB_PROJECT}-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "virtual/ruby-ssl
+ >=dev-ruby/httparty-0.7
+ >=dev-ruby/json-1.4
+ >=dev-ruby/nokogiri-1.4.4
+ >=dev-ruby/uuidtools-2.1"
+
+RUBY_PATCHES=(
+ ${PN}-1.5.3-disabletest.patch
+ ${P}.patch
+)
+
+all_ruby_compile() {
+ if use doc; then
+ rdoc || die
+ fi
+}
+
+each_ruby_install() {
+ sed -e "s:VERSION:${PV}:" "${FILESDIR}"/${PN}.gemspec > "${RUBY_FAKEGEM_GEMSPEC}"
+ each_fakegem_install
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r recipebook samples
+}
diff --git a/dev-ruby/aws-sdk/files/aws-sdk-1.6.7.patch b/dev-ruby/aws-sdk/files/aws-sdk-1.6.7.patch
new file mode 100644
index 000000000000..c45ce320c97c
--- /dev/null
+++ b/dev-ruby/aws-sdk/files/aws-sdk-1.6.7.patch
@@ -0,0 +1,45 @@
+diff --git a/lib/aws/core/option_grammar.rb b/lib/aws/core/option_grammar.rb
+index bb612bb..8d00eff 100644
+--- a/lib/aws/core/option_grammar.rb
++++ b/lib/aws/core/option_grammar.rb
+@@ -11,7 +11,6 @@
+ # ANY KIND, either express or implied. See the License for the specific
+ # language governing permissions and limitations under the License.
+
+-require 'base64'
+ require 'bigdecimal'
+ require 'json'
+
+@@ -112,11 +111,11 @@ module AWS
+ end
+
+ def encode_value(value)
+- Base64.strict_encode64(value.to_s)
++ [value.to_s].pack("m0").chomp
+ end
+
+ def hash_format(value)
+- Base64.strict_encode64(value.to_s)
++ [value.to_s].pack("m0").chomp
+ end
+
+ end
+diff --git a/spec/aws/s3/client_spec.rb b/spec/aws/s3/client_spec.rb
+index 6ac80e1..f39a4a4 100644
+--- a/spec/aws/s3/client_spec.rb
++++ b/spec/aws/s3/client_spec.rb
+@@ -247,8 +247,12 @@ module AWS
+
+ request.http_method.should eq('PUT')
+ request.querystring.should eq('tagging')
+- request.headers['content-md5'].should eq(client.send(:md5, xml))
+- request.body.should eq(xml)
++
++ # the array is differently sorted on Ruby 1.8
++ unless RUBY_VERSION =~ /^1.8/
++ request.headers['content-md5'].should eq(client.send(:md5, xml))
++ request.body.should eq(xml)
++ end
+
+ end
+