summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-11-17 20:36:44 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-11-17 20:36:44 +0000
commitaa76a1e034bdbd0be9cd768d477f6179465b5116 (patch)
tree6cc013fa9d4f49ab8a72638230b73fa1de4c57f7 /dev-ruby/bcat
parentAlters homepage to show correct address, bug #490082 (diff)
downloadgentoo-2-aa76a1e034bdbd0be9cd768d477f6179465b5116.tar.gz
gentoo-2-aa76a1e034bdbd0be9cd768d477f6179465b5116.tar.bz2
gentoo-2-aa76a1e034bdbd0be9cd768d477f6179465b5116.zip
Add ruby20 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/bcat')
-rw-r--r--dev-ruby/bcat/ChangeLog7
-rw-r--r--dev-ruby/bcat/bcat-0.6.2-r1.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-ruby/bcat/ChangeLog b/dev-ruby/bcat/ChangeLog
index 96c12242f254..3af713dabca5 100644
--- a/dev-ruby/bcat/ChangeLog
+++ b/dev-ruby/bcat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/bcat
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bcat/ChangeLog,v 1.13 2013/09/01 12:46:09 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bcat/ChangeLog,v 1.14 2013/11/17 20:36:44 mrueg Exp $
+
+*bcat-0.6.2-r1 (17 Nov 2013)
+
+ 17 Nov 2013; Manuel Rüger <mrueg@gentoo.org> +bcat-0.6.2-r1.ebuild:
+ Add ruby20 target.
01 Sep 2013; Hans de Graaff <graaff@gentoo.org> bcat-0.6.2.ebuild:
Drop virtual/ruby-test-unit which is a noop, bug 380711.
diff --git a/dev-ruby/bcat/bcat-0.6.2-r1.ebuild b/dev-ruby/bcat/bcat-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..d50e20d4da28
--- /dev/null
+++ b/dev-ruby/bcat/bcat-0.6.2-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bcat/bcat-0.6.2-r1.ebuild,v 1.1 2013/11/17 20:36:43 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC="man"
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pipe to browser utility for use at the shell and within editors like Vim or Emacs."
+HOMEPAGE="http://github.com/rtomayko/bcat"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+# Collides on /usr/bin/bcat, bug 418301
+RDEPEND="${RDEPEND} !!app-accessibility/speech-tools"
+
+ruby_add_bdepend "doc? ( app-text/ronn )"
+
+ruby_add_rdepend "dev-ruby/rack"
+
+each_ruby_prepare() {
+ sed -i -e "s/a2h/#{ENV['RUBY']} -S a2h/" test/test_bcat_a2h.rb || die
+}
+
+each_ruby_test() {
+ # The Rakefile uses weird trickery with load path that causes gems
+ # not to be found. Run tests directly instead and do the trickery
+ # here to support popen calls for the bins in this package.
+ RUBY=${RUBY} RUBYLIB=lib:${RUBYLIB} PATH=bin:${PATH} ${RUBY} -S testrb test/test_*.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/*.1
+}