summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-07-04 19:46:43 +0000
committerHans de Graaff <graaff@gentoo.org>2015-07-04 19:46:43 +0000
commit3c90e9e487d062bdc279165aaf2459adc6004011 (patch)
tree129db316b0686a9607264d8a55370047c4e81ed2 /dev-ruby/best_in_place
parentRemove mask on sys-apps/getent since its off the tree. (diff)
downloadgentoo-2-3c90e9e487d062bdc279165aaf2459adc6004011.tar.gz
gentoo-2-3c90e9e487d062bdc279165aaf2459adc6004011.tar.bz2
gentoo-2-3c90e9e487d062bdc279165aaf2459adc6004011.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/best_in_place')
-rw-r--r--dev-ruby/best_in_place/ChangeLog7
-rw-r--r--dev-ruby/best_in_place/best_in_place-3.0.3.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-ruby/best_in_place/ChangeLog b/dev-ruby/best_in_place/ChangeLog
index 7c90008834a5..79448c7410db 100644
--- a/dev-ruby/best_in_place/ChangeLog
+++ b/dev-ruby/best_in_place/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/best_in_place
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/best_in_place/ChangeLog,v 1.17 2015/06/07 16:51:05 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/best_in_place/ChangeLog,v 1.18 2015/07/04 19:46:43 graaff Exp $
+
+*best_in_place-3.0.3 (04 Jul 2015)
+
+ 04 Jul 2015; Hans de Graaff <graaff@gentoo.org> +best_in_place-3.0.3.ebuild:
+ Version bump.
07 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/dev-ruby/best_in_place/best_in_place-3.0.3.ebuild b/dev-ruby/best_in_place/best_in_place-3.0.3.ebuild
new file mode 100644
index 000000000000..2d210f4ebce8
--- /dev/null
+++ b/dev-ruby/best_in_place/best_in_place-3.0.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/best_in_place/best_in_place-3.0.3.ebuild,v 1.1 2015/07/04 19:46:43 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+# if ever needed
+#GITHUB_USER="bernat"
+#GITHUB_PROJECT="${PN}"
+#RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
+
+inherit virtualx ruby-fakegem
+
+DESCRIPTION="In-place editor helper for Rails 3"
+HOMEPAGE="https://github.com/bernat/best_in_place"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/actionpack-3.2:*
+ >=dev-ruby/railties-3.2:*
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/rdiscount
+ dev-ruby/rspec-rails:3
+ >=dev-ruby/nokogiri-1.5.0
+ >=dev-ruby/capybara-1.1.2:0
+ dev-ruby/poltergeist
+ >=dev-ruby/rails-3.2
+ >=dev-ruby/sqlite3-1.3.4-r1
+ dev-ruby/launchy
+ dev-ruby/bundler
+ )"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/git ls-files/d' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Tweak Gemfile so we can use it to run specs but can avoid missing
+ # dependencies. Also use packaged versions of jquery and jquery-ui.
+ sed -i -e '/\(rails-assets\|appraisal\)/ s:^:#:' \
+ -e '2agem "rspec", "~>3.0"' \
+ -e '2agem "jquery-rails"' -e '2agem "jquery-ui-rails"' \
+ Gemfile
+}
+
+each_ruby_test() {
+ ${RUBY} -S bundle exec rspec-3 spec || die
+}