summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-05-14 18:14:00 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-05-14 18:14:00 +0000
commit8ecedf5b5de1058e3146a93b1f0d9fe5d9d51ac1 (patch)
tree3926347ae9b836f35b07df97314858e1c5167adf /dev-ruby/best_in_place
parentremove old (diff)
downloadgentoo-2-8ecedf5b5de1058e3146a93b1f0d9fe5d9d51ac1.tar.gz
gentoo-2-8ecedf5b5de1058e3146a93b1f0d9fe5d9d51ac1.tar.bz2
gentoo-2-8ecedf5b5de1058e3146a93b1f0d9fe5d9d51ac1.zip
Version bump; replace RDiscount with kramdown and remove extra dependencies on test_app (both sent upstream). Require rails 3.2 for testing.
(Portage version: 2.2.0_alpha104/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/best_in_place')
-rw-r--r--dev-ruby/best_in_place/ChangeLog9
-rw-r--r--dev-ruby/best_in_place/best_in_place-1.1.0.ebuild62
-rw-r--r--dev-ruby/best_in_place/files/best_in_place-1.1.0-kramdown.patch35
3 files changed, 105 insertions, 1 deletions
diff --git a/dev-ruby/best_in_place/ChangeLog b/dev-ruby/best_in_place/ChangeLog
index b536b05469f0..04abc226c309 100644
--- a/dev-ruby/best_in_place/ChangeLog
+++ b/dev-ruby/best_in_place/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/best_in_place
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/best_in_place/ChangeLog,v 1.5 2012/05/11 19:30:06 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/best_in_place/ChangeLog,v 1.6 2012/05/14 18:14:00 flameeyes Exp $
+
+*best_in_place-1.1.0 (14 May 2012)
+
+ 14 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +best_in_place-1.1.0.ebuild, +files/best_in_place-1.1.0-kramdown.patch:
+ Version bump; replace RDiscount with kramdown and remove extra dependencies on
+ test_app (both sent upstream). Require rails 3.2 for testing.
11 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
best_in_place-1.0.6.ebuild:
diff --git a/dev-ruby/best_in_place/best_in_place-1.1.0.ebuild b/dev-ruby/best_in_place/best_in_place-1.1.0.ebuild
new file mode 100644
index 000000000000..7ffffe4a2120
--- /dev/null
+++ b/dev-ruby/best_in_place/best_in_place-1.1.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/best_in_place/best_in_place-1.1.0.ebuild,v 1.1 2012/05/14 18:14:00 flameeyes Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+# if ever needed
+#GITHUB_USER="bernat"
+#GITHUB_PROJECT="${PN}"
+#RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
+
+inherit virtualx ruby-fakegem
+
+DESCRIPTION="In-place editor helper for Rails 3o"
+HOMEPAGE="http://github.com/bernat/best_in_place"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rails-3.1
+ dev-ruby/jquery-rails"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/rspec-rails
+ >=dev-ruby/nokogiri-1.5.0
+ >=dev-ruby/capybara-1.0.1
+ dev-ruby/rails:3.2
+ >=dev-ruby/sqlite3-ruby-1.3.4-r1
+ dev-ruby/kramdown
+ )"
+
+DEPEND+=" test? ( www-client/firefox )"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${P}-kramdown.patch
+
+ sed -i \
+ -e '/git ls-files/d' \
+ -e '/rspec-rails/s:,.*::' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -i \
+ -e '/gem .rails/s:3.2: ~> 3.2.0:' \
+ -e '/group :assets/,/^end/ d' \
+ test_app/Gemfile || die
+}
+
+each_ruby_test() {
+ RAILS_ENV=test ${RUBY} -C test_app -S rake db:migrate || die "test_app migration failed"
+ VIRTUALX_COMMAND="${RUBY}" virtualmake -S rake spec || die "Specs failed"
+}
diff --git a/dev-ruby/best_in_place/files/best_in_place-1.1.0-kramdown.patch b/dev-ruby/best_in_place/files/best_in_place-1.1.0-kramdown.patch
new file mode 100644
index 000000000000..33ae5e0b9a68
--- /dev/null
+++ b/dev-ruby/best_in_place/files/best_in_place-1.1.0-kramdown.patch
@@ -0,0 +1,35 @@
+diff --git a/Gemfile b/Gemfile
+index 7ae9d6a..5858f12 100644
+--- a/Gemfile
++++ b/Gemfile
+@@ -5,4 +5,4 @@ gemspec
+
+ gem 'sqlite3'
+ gem 'jquery-rails'
+-gem 'rdiscount'
++gem 'kramdown'
+diff --git a/test_app/Gemfile b/test_app/Gemfile
+index 6d53037..32676b2 100644
+--- a/test_app/Gemfile
++++ b/test_app/Gemfile
+@@ -7,7 +7,7 @@ gem 'best_in_place', :path => ".."
+
+ gem 'jquery-rails'
+
+-gem 'rdiscount'
++gem 'kramdown'
+
+ group :assets do
+ gem 'sass-rails', '~> 3.2.3'
+diff --git a/test_app/app/models/user.rb b/test_app/app/models/user.rb
+index 604f5ba..7cc9248 100644
+--- a/test_app/app/models/user.rb
++++ b/test_app/app/models/user.rb
+@@ -19,6 +19,6 @@ class User < ActiveRecord::Base
+ end
+
+ def markdown_desc
+- RDiscount.new(description).to_html.html_safe
++ Kramdown::Document.new(description).to_html.html_safe
+ end
+ end