summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-12-30 10:50:16 +0000
committerHans de Graaff <graaff@gentoo.org>2014-12-30 10:50:16 +0000
commitb0fbb63627f2e2b151824d62b723d31abbf8f913 (patch)
treecc6972de5dcfaec67f13666904ed4afffb99d3af /dev-ruby/best_in_place
parentRemoved no longer used file from FILESDIR (diff)
downloadgentoo-2-b0fbb63627f2e2b151824d62b723d31abbf8f913.tar.gz
gentoo-2-b0fbb63627f2e2b151824d62b723d31abbf8f913.tar.bz2
gentoo-2-b0fbb63627f2e2b151824d62b723d31abbf8f913.zip
Add ruby20. Use correct slot for jquery-rails.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/best_in_place')
-rw-r--r--dev-ruby/best_in_place/ChangeLog5
-rw-r--r--dev-ruby/best_in_place/best_in_place-2.1.0.ebuild8
2 files changed, 8 insertions, 5 deletions
diff --git a/dev-ruby/best_in_place/ChangeLog b/dev-ruby/best_in_place/ChangeLog
index b6290e19d7d1..a92c7ebcafb0 100644
--- a/dev-ruby/best_in_place/ChangeLog
+++ b/dev-ruby/best_in_place/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/best_in_place
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/best_in_place/ChangeLog,v 1.15 2014/12/30 10:10:09 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/best_in_place/ChangeLog,v 1.16 2014/12/30 10:50:16 graaff Exp $
+
+ 30 Dec 2014; Hans de Graaff <graaff@gentoo.org> best_in_place-2.1.0.ebuild:
+ Add ruby20. Use correct slot for jquery-rails.
30 Dec 2014; Hans de Graaff <graaff@gentoo.org> best_in_place-2.1.0.ebuild:
Fix versioning issues to make all test pass again.
diff --git a/dev-ruby/best_in_place/best_in_place-2.1.0.ebuild b/dev-ruby/best_in_place/best_in_place-2.1.0.ebuild
index 3cc630867753..0bc1422c6cb8 100644
--- a/dev-ruby/best_in_place/best_in_place-2.1.0.ebuild
+++ b/dev-ruby/best_in_place/best_in_place-2.1.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/best_in_place/best_in_place-2.1.0.ebuild,v 1.3 2014/12/30 10:10:09 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/best_in_place/best_in_place-2.1.0.ebuild,v 1.4 2014/12/30 10:50:16 graaff Exp $
EAPI=5
-USE_RUBY="ruby19"
+USE_RUBY="ruby19 ruby20"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="README.md"
@@ -26,7 +26,7 @@ KEYWORDS="~amd64"
IUSE=""
ruby_add_rdepend ">=dev-ruby/rails-3.1
- dev-ruby/jquery-rails:0"
+ dev-ruby/jquery-rails:2"
ruby_add_bdepend "
test? (
@@ -58,5 +58,5 @@ all_ruby_prepare() {
each_ruby_test() {
RAILS_ENV=test ${RUBY} -C test_app -S rake db:migrate || die "test_app migration failed"
- VIRTUALX_COMMAND="${RUBY}" virtualmake -S bundle exec rspec-2 spec || die "Specs failed"
+ VIRTUALX_COMMAND="${RUBY}" virtualmake -S bundle exec ${RUBY} -S rspec-2 spec || die "Specs failed"
}