summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-01-17 19:59:21 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-01-17 19:59:21 +0000
commitc6749c523f551c5536fdc1edf067aefea826ad2f (patch)
tree48cb3e5f5f075e425f68bbfe93a3a9d50b526461 /dev-ruby/crack
parentarm stable, bug #533404 (diff)
downloadgentoo-2-c6749c523f551c5536fdc1edf067aefea826ad2f.tar.gz
gentoo-2-c6749c523f551c5536fdc1edf067aefea826ad2f.tar.bz2
gentoo-2-c6749c523f551c5536fdc1edf067aefea826ad2f.zip
Create new stable candidate.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/crack')
-rw-r--r--dev-ruby/crack/ChangeLog10
-rw-r--r--dev-ruby/crack/crack-0.3.2-r1.ebuild47
-rw-r--r--dev-ruby/crack/crack-0.4.2-r1.ebuild34
-rw-r--r--dev-ruby/crack/crack-0.4.2.ebuild6
4 files changed, 45 insertions, 52 deletions
diff --git a/dev-ruby/crack/ChangeLog b/dev-ruby/crack/ChangeLog
index ee6c42d12b07..c65c9c75230d 100644
--- a/dev-ruby/crack/ChangeLog
+++ b/dev-ruby/crack/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/crack
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/crack/ChangeLog,v 1.42 2014/12/22 13:53:43 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/crack/ChangeLog,v 1.43 2015/01/17 19:59:21 mrueg Exp $
+
+*crack-0.4.2-r1 (17 Jan 2015)
+
+ 17 Jan 2015; Manuel Rüger <mrueg@gentoo.org> +crack-0.4.2-r1.ebuild,
+ -crack-0.3.2-r1.ebuild, crack-0.4.2.ebuild:
+ Create new stable candidate.
22 Dec 2014; Agostino Sarubbo <ago@gentoo.org> crack-0.4.2.ebuild:
Add ~x86, wrt bug #491822
diff --git a/dev-ruby/crack/crack-0.3.2-r1.ebuild b/dev-ruby/crack/crack-0.3.2-r1.ebuild
deleted file mode 100644
index e6f1881dcba8..000000000000
--- a/dev-ruby/crack/crack-0.3.2-r1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/crack/crack-0.3.2-r1.ebuild,v 1.4 2014/10/30 13:45:08 mrueg Exp $
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20"
-
-# workaround for ruby 1.9.2, sent upstream after 0.1.8
-RUBY_FAKEGEM_TASK_TEST="-Ilib test"
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.rdoc History"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Really simple JSON and XML parsing, ripped from Merb and Rails"
-HOMEPAGE="https://github.com/jnunemaker/crack"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend "test? ( dev-ruby/shoulda dev-ruby/matchy )"
-
-all_ruby_prepare() {
- # By default this gem wants to use the fork of matchy from the
- # same author of itself, but we don't package that (as it's
- # neither released on gemcutter nor tagged). On the other hand it
- # works fine with the mcmire gem that we package as
- # dev-ruby/matchy.
- sed -i -e 's:jnunemaker-matchy:mcmire-matchy:' test/test_helper.rb || die
-}
-
-each_ruby_prepare() {
- case ${RUBY} in
- *ruby19|*ruby20)
- # Remove test suite that is broken for ruby19.
- # Github Issues 26, 29, 32, 33.
- rm test/json_test.rb || die
- ;;
- *)
- ;;
- esac
-}
diff --git a/dev-ruby/crack/crack-0.4.2-r1.ebuild b/dev-ruby/crack/crack-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..7387e7bb555b
--- /dev/null
+++ b/dev-ruby/crack/crack-0.4.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/crack/crack-0.4.2-r1.ebuild,v 1.1 2015/01/17 19:59:21 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md History"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Really simple JSON and XML parsing, ripped from Merb and Rails"
+HOMEPAGE="https://github.com/jnunemaker/crack"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos ~x64-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+ruby_add_rdepend ">=dev-ruby/safe_yaml-1.0.0"
+
+each_ruby_prepare() {
+ # Remove tests which fail when run by portage but pass when run by hand
+ sed -i -e '/{"regex": \/foo.*\/}/d' test/json_test.rb || die
+ sed -i -e '/{"regex": \/foo.*\/i}/d' test/json_test.rb || die
+ sed -i -e '/{"regex": \/foo.*\/mix}/d' test/json_test.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Itest -Ilib -e 'Dir["test/*_test.rb"].each { |f| load f }' || die
+}
diff --git a/dev-ruby/crack/crack-0.4.2.ebuild b/dev-ruby/crack/crack-0.4.2.ebuild
index 32ec6ebb4050..893621c24f89 100644
--- a/dev-ruby/crack/crack-0.4.2.ebuild
+++ b/dev-ruby/crack/crack-0.4.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/crack/crack-0.4.2.ebuild,v 1.7 2014/12/22 13:53:43 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/crack/crack-0.4.2.ebuild,v 1.8 2015/01/17 19:59:21 mrueg Exp $
EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21"
+USE_RUBY="ruby19 ruby20"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="README.md History"