summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-03-08 06:39:58 +0000
committerHans de Graaff <graaff@gentoo.org>2013-03-08 06:39:58 +0000
commitda698a6ea17ce0e6ed7868fd06564b45ea559644 (patch)
tree67d6c0227111b2366a65be50e3c07b33ac740e93 /dev-ruby/haml
parentVersion bump. (diff)
downloadgentoo-2-da698a6ea17ce0e6ed7868fd06564b45ea559644.tar.gz
gentoo-2-da698a6ea17ce0e6ed7868fd06564b45ea559644.tar.bz2
gentoo-2-da698a6ea17ce0e6ed7868fd06564b45ea559644.zip
Version bump.
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/haml')
-rw-r--r--dev-ruby/haml/ChangeLog7
-rw-r--r--dev-ruby/haml/haml-3.1.8.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-ruby/haml/ChangeLog b/dev-ruby/haml/ChangeLog
index 3ed724ead638..3ec4d52a1d94 100644
--- a/dev-ruby/haml/ChangeLog
+++ b/dev-ruby/haml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/haml
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.82 2013/02/03 11:06:39 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.83 2013/03/08 06:39:58 graaff Exp $
+
+*haml-3.1.8 (08 Mar 2013)
+
+ 08 Mar 2013; Hans de Graaff <graaff@gentoo.org> +haml-3.1.8.ebuild:
+ Version bump.
03 Feb 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due #63939
diff --git a/dev-ruby/haml/haml-3.1.8.ebuild b/dev-ruby/haml/haml-3.1.8.ebuild
new file mode 100644
index 000000000000..6797cfc468be
--- /dev/null
+++ b/dev-ruby/haml/haml-3.1.8.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/haml-3.1.8.ebuild,v 1.1 2013/03/08 06:39:58 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+RUBY_FAKEGEM_TASK_DOC="-Ilib doc"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING README.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb rails VERSION VERSION_NAME"
+
+inherit ruby-fakegem
+
+DESCRIPTION="HAML - a ruby web page templating engine"
+HOMEPAGE="http://haml-lang.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# TODO: haml has some emacs modes that it could be installing, in case
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/sass"
+
+# It could use merb during testing as well, but it's not mandatory
+ruby_add_bdepend "
+ test? (
+ dev-ruby/minitest
+ dev-ruby/hpricot
+ dev-ruby/erubis
+ dev-ruby/rails
+ dev-ruby/ruby_parser
+ >=dev-ruby/sass-3.2.0
+ )
+ doc? (
+ dev-ruby/yard
+ dev-ruby/maruku
+ dev-ruby/sass
+ )"
+
+all_ruby_prepare() {
+ # unbundle sass; remove dependency over fssm and add one over sass
+ # itself.
+ rm -r vendor/ || die
+
+ pushd .. &>/dev/null
+ epatch "${FILESDIR}"/${PN}-3.1.6-sass.patch
+ sed -i \
+ -e '/vendor\//d' \
+ metadata || die
+ popd &>/dev/null
+
+ # Use newer sass and update specs to make a consistent combination.
+ sed -i -e 's/fuchsia/magenta/' test/haml/results/filters.xhtml || die
+}