summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-07-25 13:35:15 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-07-25 13:35:15 +0000
commit3c82f97e4a8fc6f01350a981ca5c67e4e751b00e (patch)
treea46b18a5f5f2b6b7427e778bfe34f279011c1cf6 /dev-ruby/json
parentCleanup old. (diff)
downloadgentoo-2-3c82f97e4a8fc6f01350a981ca5c67e4e751b00e.tar.gz
gentoo-2-3c82f97e4a8fc6f01350a981ca5c67e4e751b00e.tar.bz2
gentoo-2-3c82f97e4a8fc6f01350a981ca5c67e4e751b00e.zip
Cleanup old.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/json')
-rw-r--r--dev-ruby/json/ChangeLog6
-rw-r--r--dev-ruby/json/json-1.7.7-r1.ebuild68
-rw-r--r--dev-ruby/json/json-1.7.7.ebuild65
3 files changed, 5 insertions, 134 deletions
diff --git a/dev-ruby/json/ChangeLog b/dev-ruby/json/ChangeLog
index 444b996ad4ea..b94e3bb97776 100644
--- a/dev-ruby/json/ChangeLog
+++ b/dev-ruby/json/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/json
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.145 2014/04/19 02:52:45 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.146 2014/07/25 13:35:15 mrueg Exp $
+
+ 25 Jul 2014; Manuel Rüger <mrueg@gentoo.org> -json-1.7.7-r1.ebuild,
+ -json-1.7.7.ebuild:
+ Cleanup old.
19 Apr 2014; Manuel Rüger <mrueg@gentoo.org> -json-1.6.8.ebuild:
Cleanup old.
diff --git a/dev-ruby/json/json-1.7.7-r1.ebuild b/dev-ruby/json/json-1.7.7-r1.ebuild
deleted file mode 100644
index 50d09513c32c..000000000000
--- a/dev-ruby/json/json-1.7.7-r1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.7.7-r1.ebuild,v 1.2 2014/04/05 23:40:47 mrueg Exp $
-
-EAPI=5
-USE_RUBY="ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README.rdoc README-json-jruby.markdown"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_GEMSPEC="json.gemspec"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A JSON implementation as a Ruby extension."
-HOMEPAGE="http://json.rubyforge.org/"
-LICENSE="|| ( Ruby GPL-2 )"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-RDEPEND="${RDEPEND}"
-DEPEND="${DEPEND}
- dev-util/ragel"
-
-ruby_add_bdepend "dev-ruby/rake"
-
-all_ruby_prepare() {
- # Avoid building the extension twice!
- # And use rdoc instead of sdoc which we don't have packaged
- # And don't call git to list files. We're using the pregenerated spec anyway.
- sed -i \
- -e 's| => :compile||' \
- -e 's| => :clean||' \
- -e 's|sdoc|rdoc|' \
- -e 's|`git ls-files`|""|' \
- Rakefile || die "rakefile fix failed"
-
- # Remove hardcoded and broken -O setting.
- sed -i -e '/^unless/,/^end/ d' -e '/^ (if|unless)/,/^ end/ d' ext/json/ext/*/extconf.rb || die
-}
-
-each_ruby_compile() {
- # Since 1.5.0 a Java extension is provided but it does not compile.
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- ${RUBY} -S rake compile || die "extension compile failed"
- fi
-}
-
-each_ruby_test() {
- JSON=pure \
- ${RUBY} -Iext:lib -S testrb tests/test_*.rb || die "pure ruby tests failed"
-
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- JSON=ext \
- ${RUBY} -Iext:lib -S testrb tests/test_*.rb || die "ext ruby tests failed"
- fi
-}
-
-each_ruby_install() {
- each_fakegem_install
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- ruby_fakegem_newins ext/json/ext/generator$(get_modname) lib/json/ext/generator$(get_modname)
- ruby_fakegem_newins ext/json/ext/parser$(get_modname) lib/json/ext/parser$(get_modname)
- fi
-}
diff --git a/dev-ruby/json/json-1.7.7.ebuild b/dev-ruby/json/json-1.7.7.ebuild
deleted file mode 100644
index 955b09ccd2a6..000000000000
--- a/dev-ruby/json/json-1.7.7.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.7.7.ebuild,v 1.14 2014/04/05 23:40:47 mrueg Exp $
-
-EAPI=5
-USE_RUBY="ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README.rdoc README-json-jruby.markdown"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_GEMSPEC="json.gemspec"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A JSON implementation as a Ruby extension."
-HOMEPAGE="http://json.rubyforge.org/"
-LICENSE="|| ( Ruby GPL-2 )"
-
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-RDEPEND="${RDEPEND}"
-DEPEND="${DEPEND}
- dev-util/ragel"
-
-ruby_add_bdepend "dev-ruby/rake"
-
-all_ruby_prepare() {
- # Avoid building the extension twice!
- # And use rdoc instead of sdoc which we don't have packaged
- # And don't call git to list files. We're using the pregenerated spec anyway.
- sed -i \
- -e 's| => :compile||' \
- -e 's| => :clean||' \
- -e 's|sdoc|rdoc|' \
- -e 's|`git ls-files`|""|' \
- Rakefile || die "rakefile fix failed"
-}
-
-each_ruby_compile() {
- # Since 1.5.0 a Java extension is provided but it does not compile.
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- ${RUBY} -S rake compile || die "extension compile failed"
- fi
-}
-
-each_ruby_test() {
- JSON=pure \
- ${RUBY} -Iext:lib -S testrb tests/test_*.rb || die "pure ruby tests failed"
-
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- JSON=ext \
- ${RUBY} -Iext:lib -S testrb tests/test_*.rb || die "ext ruby tests failed"
- fi
-}
-
-each_ruby_install() {
- each_fakegem_install
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- ruby_fakegem_newins ext/json/ext/generator$(get_modname) lib/json/ext/generator$(get_modname)
- ruby_fakegem_newins ext/json/ext/parser$(get_modname) lib/json/ext/parser$(get_modname)
- fi
-}