summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-12-01 10:32:34 +0000
committerHans de Graaff <graaff@gentoo.org>2012-12-01 10:32:34 +0000
commit46e76880af7a205a78f215a6cfa212d9e92988a2 (patch)
treef9f29a2ba05b04e02bd60b4eac39e26e90439809 /dev-ruby/kramdown
parentRemove old. (diff)
downloadgentoo-2-46e76880af7a205a78f215a6cfa212d9e92988a2.tar.gz
gentoo-2-46e76880af7a205a78f215a6cfa212d9e92988a2.tar.bz2
gentoo-2-46e76880af7a205a78f215a6cfa212d9e92988a2.zip
Version bump. Add missing htmltidy test dependency thanks to mrueg.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/kramdown')
-rw-r--r--dev-ruby/kramdown/ChangeLog7
-rw-r--r--dev-ruby/kramdown/kramdown-0.14.1.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-ruby/kramdown/ChangeLog b/dev-ruby/kramdown/ChangeLog
index d36a38983fca..366889ee5b70 100644
--- a/dev-ruby/kramdown/ChangeLog
+++ b/dev-ruby/kramdown/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/kramdown
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/kramdown/ChangeLog,v 1.17 2012/09/16 22:53:17 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/kramdown/ChangeLog,v 1.18 2012/12/01 10:32:34 graaff Exp $
+
+*kramdown-0.14.1 (01 Dec 2012)
+
+ 01 Dec 2012; Hans de Graaff <graaff@gentoo.org> +kramdown-0.14.1.ebuild:
+ Version bump. Add missing htmltidy test dependency thanks to mrueg.
*kramdown-0.14.0 (16 Sep 2012)
diff --git a/dev-ruby/kramdown/kramdown-0.14.1.ebuild b/dev-ruby/kramdown/kramdown-0.14.1.ebuild
new file mode 100644
index 000000000000..057dd6cca8f5
--- /dev/null
+++ b/dev-ruby/kramdown/kramdown-0.14.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/kramdown/kramdown-0.14.1.ebuild,v 1.1 2012/12/01 10:32:34 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_EXTRADOC="README.md AUTHORS ChangeLog CONTRIBUTERS"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="yet-another-markdown-parser but fast, pure Ruby, using a strict syntax definition."
+HOMEPAGE="http://kramdown.rubyforge.org/"
+
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="latex"
+
+LATEX_DEPS="latex? ( dev-texlive/texlive-latex dev-texlive/texlive-latexextra )"
+RDEPEND+=" ${LATEX_DEPS}"
+DEPEND+=" test? ( ${LATEX_DEPS} app-text/htmltidy )"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )
+ test? ( >=dev-ruby/coderay-1.0.0 )"
+
+all_ruby_prepare() {
+ if ! use latex; then
+ # Remove latex tests. They will fail gracefully when latex isn't
+ # present at all, but not when components are missing (most
+ # notable ucs.sty).
+ sed -i -e '/latex -v/,/^ end/ s:^:#:' test/test_files.rb || die
+ fi
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/man1/kramdown.1
+}