summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-03-07 00:10:30 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-03-07 00:10:30 +0000
commitdac20ab6df466edd30d8f236f5cc60c03ac59f16 (patch)
tree0a4f419d7c86a58940389314ec3d02b503d51849 /dev-ruby/msgpack/msgpack-0.5.8.ebuild
parentVersion bump by Peter Wilmott. Cleanup old. (diff)
downloadgentoo-2-dac20ab6df466edd30d8f236f5cc60c03ac59f16.tar.gz
gentoo-2-dac20ab6df466edd30d8f236f5cc60c03ac59f16.tar.bz2
gentoo-2-dac20ab6df466edd30d8f236f5cc60c03ac59f16.zip
Version bump. Drop ruby18.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/msgpack/msgpack-0.5.8.ebuild')
-rw-r--r--dev-ruby/msgpack/msgpack-0.5.8.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/msgpack/msgpack-0.5.8.ebuild b/dev-ruby/msgpack/msgpack-0.5.8.ebuild
new file mode 100644
index 000000000000..048ec12fac41
--- /dev/null
+++ b/dev-ruby/msgpack/msgpack-0.5.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/msgpack/msgpack-0.5.8.ebuild,v 1.1 2014/03/07 00:10:30 mrueg Exp $
+
+EAPI=5
+
+# jruby → uses a binary extension
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Binary-based efficient data interchange format for ruby binding"
+HOMEPAGE="http://msgpack.sourceforge.jp/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="doc"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${PN} extconf.rb || die "Configuration of extension failed."
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/${PN}
+ cp ext/${PN}/msgpack$(get_modname) lib/${PN} || die "Unable to install msgpack library."
+}