summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-05-30 07:02:46 +0000
committerHans de Graaff <graaff@gentoo.org>2014-05-30 07:02:46 +0000
commitc51569eab5f031e638546559e4ee927fc1b33315 (patch)
tree5497ed67759ec1c9cdf4a609bb8bc339bd45825c /dev-ruby/narray
parentVersion bump. Add ruby21. (diff)
downloadgentoo-2-c51569eab5f031e638546559e4ee927fc1b33315.tar.gz
gentoo-2-c51569eab5f031e638546559e4ee927fc1b33315.tar.bz2
gentoo-2-c51569eab5f031e638546559e4ee927fc1b33315.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/narray')
-rw-r--r--dev-ruby/narray/ChangeLog7
-rw-r--r--dev-ruby/narray/narray-0.6.0.9.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-ruby/narray/ChangeLog b/dev-ruby/narray/ChangeLog
index 2cb8062ba2e2..8c045c18b9e7 100644
--- a/dev-ruby/narray/ChangeLog
+++ b/dev-ruby/narray/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/narray
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/ChangeLog,v 1.66 2014/05/24 10:11:42 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/ChangeLog,v 1.67 2014/05/30 07:02:46 graaff Exp $
+
+*narray-0.6.0.9 (30 May 2014)
+
+ 30 May 2014; Hans de Graaff <graaff@gentoo.org> +narray-0.6.0.9.ebuild:
+ Version bump.
24 May 2014; Agostino Sarubbo <ago@gentoo.org> narray-0.6.0.8-r1.ebuild:
Stable for x86, wrt bug #506290
diff --git a/dev-ruby/narray/narray-0.6.0.9.ebuild b/dev-ruby/narray/narray-0.6.0.9.ebuild
new file mode 100644
index 000000000000..0acda6638f2c
--- /dev/null
+++ b/dev-ruby/narray/narray-0.6.0.9.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/narray-0.6.0.9.ebuild,v 1.1 2014/05/30 07:02:46 graaff Exp $
+
+EAPI=5
+
+# jruby → native extension
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.md README.ja.md SPEC.en.txt SPEC.ja.txt"
+
+RUBY_FAKEGEM_VERSION="${PV/_p/.}"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Numerical N-dimensional Array class"
+HOMEPAGE="http://www.ir.isas.ac.jp/~masa/ruby/index-e.html"
+SRC_URI="https://github.com/masa16/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~x86"
+
+IUSE=""
+
+all_ruby_prepare() {
+ # the tests aren't really written to be a testsuite, so the
+ # failure cases will literally fail; ignore all of those and
+ # instead expect that the rest won't fail.
+ sed -i -e '/[fF]ollowing will fail/,$ s:^:#:' \
+ -e '/next will fail/,$ s:^:#:' \
+ test/*.rb || die "sed failed"
+}
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake V=1 CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
+ cp -l ${PN}$(get_modname) ${PN}.h ${PN}_config.h lib/ || die "copy of ${PN}$(get_modname) failed"
+}
+
+each_ruby_test() {
+ for unit in test/*; do
+ # Skip over the FFTW test because it needs a package we don't
+ # have in tree.
+ [[ ${unit} == test/testfftw.rb ]] && continue
+
+ ${RUBY} -Ilib ${unit} || die "test ${unit} failed"
+ done
+}