summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-06-26 07:12:23 +0000
committerHans de Graaff <graaff@gentoo.org>2011-06-26 07:12:23 +0000
commit052d93d1e5c17a9f66e225f62149893c19bc8a86 (patch)
treea1e6d0b41519fba98a64ed0971ecf88373bb90bf /dev-ruby/oauth
parentRemove old version. (diff)
downloadgentoo-2-052d93d1e5c17a9f66e225f62149893c19bc8a86.tar.gz
gentoo-2-052d93d1e5c17a9f66e225f62149893c19bc8a86.tar.bz2
gentoo-2-052d93d1e5c17a9f66e225f62149893c19bc8a86.zip
Version bump.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/oauth')
-rw-r--r--dev-ruby/oauth/ChangeLog7
-rw-r--r--dev-ruby/oauth/oauth-0.4.5.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-ruby/oauth/ChangeLog b/dev-ruby/oauth/ChangeLog
index 41849492bfab..7597d40b5cb3 100644
--- a/dev-ruby/oauth/ChangeLog
+++ b/dev-ruby/oauth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/oauth
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/ChangeLog,v 1.15 2011/06/26 07:04:11 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/ChangeLog,v 1.16 2011/06/26 07:12:23 graaff Exp $
+
+*oauth-0.4.5 (26 Jun 2011)
+
+ 26 Jun 2011; Hans de Graaff <graaff@gentoo.org> +oauth-0.4.5.ebuild:
+ Version bump.
26 Jun 2011; Hans de Graaff <graaff@gentoo.org> -oauth-0.4.3.ebuild:
Remove old version.
diff --git a/dev-ruby/oauth/oauth-0.4.5.ebuild b/dev-ruby/oauth/oauth-0.4.5.ebuild
new file mode 100644
index 000000000000..ace993b33598
--- /dev/null
+++ b/dev-ruby/oauth/oauth-0.4.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/oauth-0.4.5.ebuild,v 1.1 2011/06/26 07:12:23 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="HISTORY README.rdoc TODO"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A RubyGem for implementing both OAuth clients and servers."
+HOMEPAGE="http://oauth.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+IUSE=""
+
+ruby_add_bdepend "test? ( virtual/ruby-test-unit
+ >=dev-ruby/actionpack-2.3.8:2.3
+ dev-ruby/mocha
+ dev-ruby/webmock )"
+
+all_ruby_prepare() {
+ # Ensure a consistent test order to avoid loading issues with e.g. rack
+ sed -i -e "s/.rb']/.rb'].sort/" Rakefile || die
+}