summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-05-15 02:00:33 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-05-15 02:00:33 +0000
commit38b8ee0087ab65cc846d9ad7401128640083656f (patch)
tree5c7ce10134a3548543637c5f16342c229b47decb /dev-ruby/priorityqueue
parentbump; drop py2.6 add py3.4 pypy support (diff)
downloadgentoo-2-38b8ee0087ab65cc846d9ad7401128640083656f.tar.gz
gentoo-2-38b8ee0087ab65cc846d9ad7401128640083656f.tar.bz2
gentoo-2-38b8ee0087ab65cc846d9ad7401128640083656f.zip
Initial ebuild.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/priorityqueue')
-rw-r--r--dev-ruby/priorityqueue/ChangeLog9
-rw-r--r--dev-ruby/priorityqueue/metadata.xml5
-rw-r--r--dev-ruby/priorityqueue/priorityqueue-0.1.2.ebuild38
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-ruby/priorityqueue/ChangeLog b/dev-ruby/priorityqueue/ChangeLog
new file mode 100644
index 000000000000..0da60256aa3d
--- /dev/null
+++ b/dev-ruby/priorityqueue/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-ruby/priorityqueue
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/priorityqueue/ChangeLog,v 1.1 2014/05/15 02:00:33 mrueg Exp $
+
+*priorityqueue-0.1.2 (15 May 2014)
+
+ 15 May 2014; Manuel Rüger <mrueg@gentoo.org> +metadata.xml,
+ +priorityqueue-0.1.2.ebuild:
+ Initial ebuild.
diff --git a/dev-ruby/priorityqueue/metadata.xml b/dev-ruby/priorityqueue/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/priorityqueue/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/priorityqueue/priorityqueue-0.1.2.ebuild b/dev-ruby/priorityqueue/priorityqueue-0.1.2.ebuild
new file mode 100644
index 000000000000..4f215692db03
--- /dev/null
+++ b/dev-ruby/priorityqueue/priorityqueue-0.1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/priorityqueue/priorityqueue-0.1.2.ebuild,v 1.1 2014/05/15 02:00:33 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+RUBY_FAKEGEM_NAME="PriorityQueue"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A fibonacci-heap priority-queue implementation"
+HOMEPAGE="https://rubygems.org/gems/PriorityQueue"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ rm Makefile *.o *.so || die
+}
+
+each_ruby_configure() {
+ ${RUBY} setup.rb config || die
+}
+
+each_ruby_compile() {
+ ${RUBY} setup.rb setup || die
+ cp ext/priority_queue/*$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/priority_queue_test.rb || die
+}