summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-07-07 09:35:59 +0000
committerHans de Graaff <graaff@gentoo.org>2011-07-07 09:35:59 +0000
commit62a966ad1e05e90ac492a204cad2ad1351542c52 (patch)
treedc510a0fa9b2e8a6c1ede7ba579cad45ac9289c8 /dev-ruby/racc
parentFix for atlas detection as blas implementation (diff)
downloadgentoo-2-62a966ad1e05e90ac492a204cad2ad1351542c52.tar.gz
gentoo-2-62a966ad1e05e90ac492a204cad2ad1351542c52.tar.bz2
gentoo-2-62a966ad1e05e90ac492a204cad2ad1351542c52.zip
Revision bump to create stable candidate.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/racc')
-rw-r--r--dev-ruby/racc/ChangeLog8
-rw-r--r--dev-ruby/racc/racc-1.4.6-r1.ebuild77
-rw-r--r--dev-ruby/racc/racc-1.4.6.ebuild4
3 files changed, 86 insertions, 3 deletions
diff --git a/dev-ruby/racc/ChangeLog b/dev-ruby/racc/ChangeLog
index d3644a131a62..7d883e89b21c 100644
--- a/dev-ruby/racc/ChangeLog
+++ b/dev-ruby/racc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/racc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/ChangeLog,v 1.54 2011/02/20 13:02:47 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/ChangeLog,v 1.55 2011/07/07 09:35:59 graaff Exp $
+
+*racc-1.4.6-r1 (07 Jul 2011)
+
+ 07 Jul 2011; Hans de Graaff <graaff@gentoo.org> racc-1.4.6.ebuild,
+ +racc-1.4.6-r1.ebuild:
+ Revision bump to create stable candidate.
20 Feb 2011; Hans de Graaff <graaff@gentoo.org> racc-1.4.6.ebuild:
Always depend on dev-ruby/rake since we use it to build the package. Fixes
diff --git a/dev-ruby/racc/racc-1.4.6-r1.ebuild b/dev-ruby/racc/racc-1.4.6-r1.ebuild
new file mode 100644
index 000000000000..d87e984f69c1
--- /dev/null
+++ b/dev-ruby/racc/racc-1.4.6-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/racc-1.4.6-r1.ebuild,v 1.1 2011/07/07 09:35:59 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ree18 ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.en.rdoc README.ja.rdoc TODO ChangeLog"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A LALR(1) parser generator for Ruby"
+HOMEPAGE="http://www.loveruby.net/en/racc.html"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "dev-ruby/rake test? ( virtual/ruby-test-unit )"
+
+all_ruby_prepare() {
+ # for Ruby 1.9.2 compatibility
+ sed -i -e '1i $: << "."' Rakefile || die
+
+ sed -i -e '/tasks\/email/s:^:#:' Rakefile || die "rakefile fix failed"
+ sed -i -e '/prerequisites/s:^:#:' tasks/test.rb || die "test task fix failed"
+ sed -i -e 's|/tmp/out|${TMPDIR:-/tmp}/out|' test/helper.rb || die "tests fix failed"
+
+ epatch "${FILESDIR}"/${P}-test-unit.patch
+}
+
+each_ruby_prepare() {
+ if [[ $(basename ${RUBY}) == "ruby18" ]]; then
+ sed -i -e 's:ruby/ruby.h:ruby.h:' \
+ ext/racc/cparse/cparse.c || die
+ fi
+}
+
+each_ruby_compile() {
+ case ${RUBY} in
+ *jruby)
+ einfo "Under JRuby, racc cannot use the shared object parser, so instead"
+ einfo "you have to rely on the pure Ruby implementation."
+ ;;
+ *)
+ ${RUBY} -S rake build || die "build failed"
+ # Copy over the file here so that we don't have to do
+ # special ruby install for JRuby and the other
+ # implementations.
+ cp -l ext/racc/cparse/cparse$(get_modname) lib/racc/cparse$(get_modname) || die
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ewarn "Using JRuby 1.5.2 the tests are currently badly broken,"
+ ewarn "so they are disabled until a new racc or a new JRuby is"
+ ewarn "released."
+ ;;
+ *)
+ each_fakegem_test
+ ;;
+ esac
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc sample/* || die
+}
diff --git a/dev-ruby/racc/racc-1.4.6.ebuild b/dev-ruby/racc/racc-1.4.6.ebuild
index 1896d41e63e2..03a9c813b056 100644
--- a/dev-ruby/racc/racc-1.4.6.ebuild
+++ b/dev-ruby/racc/racc-1.4.6.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/racc-1.4.6.ebuild,v 1.11 2011/02/20 13:02:47 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/racc-1.4.6.ebuild,v 1.12 2011/07/07 09:35:59 graaff Exp $
EAPI=2
-USE_RUBY="ree18 ruby18 ruby19 jruby"
+USE_RUBY="ree18 ruby18 jruby"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="README.en.rdoc README.ja.rdoc TODO ChangeLog"