summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-10-20 06:09:22 +0000
committerHans de Graaff <graaff@gentoo.org>2011-10-20 06:09:22 +0000
commit9d52008281808835eea6f4e3e1740bc8acead174 (patch)
tree9308b3ca395c6ff2432911e85cad7d423dda068c /dev-ruby/racc
parentRemove old version. (diff)
downloadgentoo-2-9d52008281808835eea6f4e3e1740bc8acead174.tar.gz
gentoo-2-9d52008281808835eea6f4e3e1740bc8acead174.tar.bz2
gentoo-2-9d52008281808835eea6f4e3e1740bc8acead174.zip
Version
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/racc')
-rw-r--r--dev-ruby/racc/ChangeLog7
-rw-r--r--dev-ruby/racc/racc-1.4.7.ebuild79
2 files changed, 85 insertions, 1 deletions
diff --git a/dev-ruby/racc/ChangeLog b/dev-ruby/racc/ChangeLog
index 6b68b9b92622..764a335146b4 100644
--- a/dev-ruby/racc/ChangeLog
+++ b/dev-ruby/racc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/racc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/ChangeLog,v 1.62 2011/10/20 05:49:36 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/ChangeLog,v 1.63 2011/10/20 06:09:22 graaff Exp $
+
+*racc-1.4.7 (20 Oct 2011)
+
+ 20 Oct 2011; Hans de Graaff <graaff@gentoo.org> +racc-1.4.7.ebuild:
+ Version bump.
20 Oct 2011; Hans de Graaff <graaff@gentoo.org> -racc-1.4.5.ebuild:
Remove old version.
diff --git a/dev-ruby/racc/racc-1.4.7.ebuild b/dev-ruby/racc/racc-1.4.7.ebuild
new file mode 100644
index 000000000000..d4d97e66e4bd
--- /dev/null
+++ b/dev-ruby/racc/racc-1.4.7.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/racc-1.4.7.ebuild,v 1.1 2011/10/20 06:09:22 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ree18 ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.rdoc README.ja.rdoc TODO ChangeLog"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A LALR(1) parser generator for Ruby"
+HOMEPAGE="http://www.loveruby.net/en/racc.html"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "dev-ruby/rake"
+
+all_ruby_prepare() {
+ # for Ruby 1.9.2 compatibility
+ sed -i -e '1i $: << "."' Rakefile || die
+
+ sed -i -e '/tasks\/email/s:^:#:' Rakefile || die "rakefile fix failed"
+ sed -i -e 's|/tmp/out|${TMPDIR:-/tmp}/out|' test/helper.rb || die "tests fix failed"
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ ${RUBY} -Cext/racc extconf.rb || die
+ ;;
+ esac
+}
+
+each_ruby_compile() {
+ case ${RUBY} in
+ *jruby)
+ einfo "Under JRuby, racc cannot use the shared object parser, so instead"
+ einfo "you have to rely on the pure Ruby implementation."
+ ;;
+ *)
+ emake -Cext/racc
+ # Copy over the file here so that we don't have to do
+ # special ruby install for JRuby and the other
+ # implementations.
+ cp -l ext/racc/cparse$(get_modname) lib/racc/cparse$(get_modname) || die
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ewarn "Using JRuby 1.5.2 the tests are currently badly broken,"
+ ewarn "so they are disabled until a new racc or a new JRuby is"
+ ewarn "released."
+ ;;
+ *)
+ each_fakegem_test
+ ;;
+ esac
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc -r rdoc
+
+ docinto examples
+ dodoc -r sample
+}