summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-01-22 18:49:43 +0000
committerHans de Graaff <graaff@gentoo.org>2012-01-22 18:49:43 +0000
commit7285aa2e7bd39f6466d58715ba4febedddd1710f (patch)
tree4fc831ffd9b5da00f62ff66c1d3feb43544bd095 /dev-ruby/rack
parentInitial import of syslogger to use with Rails. (diff)
downloadgentoo-2-7285aa2e7bd39f6466d58715ba4febedddd1710f.tar.gz
gentoo-2-7285aa2e7bd39f6466d58715ba4febedddd1710f.tar.bz2
gentoo-2-7285aa2e7bd39f6466d58715ba4febedddd1710f.zip
Remove old versions.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rack')
-rw-r--r--dev-ruby/rack/ChangeLog7
-rw-r--r--dev-ruby/rack/rack-1.1.0-r1.ebuild39
-rw-r--r--dev-ruby/rack/rack-1.1.0.ebuild43
-rw-r--r--dev-ruby/rack/rack-1.1.2.ebuild39
-rw-r--r--dev-ruby/rack/rack-1.2.3.ebuild47
-rw-r--r--dev-ruby/rack/rack-1.2.4.ebuild47
-rw-r--r--dev-ruby/rack/rack-1.3.5.ebuild56
7 files changed, 6 insertions, 272 deletions
diff --git a/dev-ruby/rack/ChangeLog b/dev-ruby/rack/ChangeLog
index 2348213e9865..f1094fd1bbfb 100644
--- a/dev-ruby/rack/ChangeLog
+++ b/dev-ruby/rack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rack
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/ChangeLog,v 1.73 2012/01/08 15:36:38 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/ChangeLog,v 1.74 2012/01/22 18:49:43 graaff Exp $
+
+ 22 Jan 2012; Hans de Graaff <graaff@gentoo.org> -rack-1.1.0.ebuild,
+ -rack-1.1.0-r1.ebuild, -rack-1.1.2.ebuild, -rack-1.2.3.ebuild,
+ -rack-1.2.4.ebuild, -rack-1.3.5.ebuild:
+ Remove old versions.
08 Jan 2012; Raúl Porcel <armin76@gentoo.org> rack-1.1.3.ebuild:
ia64/sparc stable wrt #396455
diff --git a/dev-ruby/rack/rack-1.1.0-r1.ebuild b/dev-ruby/rack/rack-1.1.0-r1.ebuild
deleted file mode 100644
index 30fb7c1e8516..000000000000
--- a/dev-ruby/rack/rack-1.1.0-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.1.0-r1.ebuild,v 1.4 2011/12/29 06:52:38 graaff Exp $
-
-EAPI="2"
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="A modular Ruby webserver interface"
-HOMEPAGE="http://rubyforge.org/projects/rack"
-SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-# The gem has automagic dependencies over mongrel, ruby-openid,
-# memcache-client, thin, mongrel and camping; not sure if we should
-# make them dependencies at all.
-ruby_add_bdepend test dev-ruby/test-spec
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
-}
-
-each_ruby_test() {
- # Since the Rakefile calls specrb directly rather than loading it, we
- # cannot use it to launch the tests or only the currently-selected
- # RUBY interpreter will be tested.
- ${RUBY} -S specrb -Ilib:test -w -a \
- -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|rackup)' \
- || die "test failed for ${RUBY}"
-}
diff --git a/dev-ruby/rack/rack-1.1.0.ebuild b/dev-ruby/rack/rack-1.1.0.ebuild
deleted file mode 100644
index 3e4187483b99..000000000000
--- a/dev-ruby/rack/rack-1.1.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.1.0.ebuild,v 1.12 2011/07/24 17:16:15 armin76 Exp $
-
-EAPI="2"
-USE_RUBY="ruby18 ree18 jruby"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="A modular Ruby webserver interface"
-HOMEPAGE="http://rubyforge.org/projects/rack"
-SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ia64 ppc ppc64 sparc x86 ~amd64-linux ~ia64-linux ~x86-linux ~x64-solaris ~x86-solaris"
-IUSE=""
-
-# The gem has automagic dependencies over mongrel, ruby-openid,
-# memcache-client, thin, mongrel and camping; not sure if we should
-# make them dependencies at all.
-ruby_add_bdepend test dev-ruby/test-spec
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
-}
-
-each_ruby_test() {
- # Since the Rakefile calls specrb directly rather than loading it, we
- # cannot use it to launch the tests or only the currently-selected
- # RUBY interpreter will be tested.
- ${RUBY} -S specrb -Ilib:test -w -a \
- -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|rackup)' \
- || die "test failed for ${RUBY}"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- ruby_fakegem_binwrapper rackup
-}
diff --git a/dev-ruby/rack/rack-1.1.2.ebuild b/dev-ruby/rack/rack-1.1.2.ebuild
deleted file mode 100644
index 53fa205b9eb8..000000000000
--- a/dev-ruby/rack/rack-1.1.2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.1.2.ebuild,v 1.3 2011/12/29 06:52:38 graaff Exp $
-
-EAPI="2"
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="A modular Ruby webserver interface"
-HOMEPAGE="http://rubyforge.org/projects/rack"
-SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-# The gem has automagic dependencies over mongrel, ruby-openid,
-# memcache-client, thin, mongrel and camping; not sure if we should
-# make them dependencies at all.
-ruby_add_bdepend test dev-ruby/test-spec
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${PN}-1.1.0-gentoo.patch
-}
-
-each_ruby_test() {
- # Since the Rakefile calls specrb directly rather than loading it, we
- # cannot use it to launch the tests or only the currently-selected
- # RUBY interpreter will be tested.
- ${RUBY} -S specrb -Ilib:test -w -a \
- -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|rackup)' \
- || die "test failed for ${RUBY}"
-}
diff --git a/dev-ruby/rack/rack-1.2.3.ebuild b/dev-ruby/rack/rack-1.2.3.ebuild
deleted file mode 100644
index bee79a313e2b..000000000000
--- a/dev-ruby/rack/rack-1.2.3.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.2.3.ebuild,v 1.4 2011/09/09 07:28:34 grobian Exp $
-
-EAPI="2"
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="ChangeLog KNOWN-ISSUES README SPEC"
-
-inherit ruby-fakegem eutils versionator
-
-DESCRIPTION="A modular Ruby webserver interface"
-HOMEPAGE="http://rubyforge.org/projects/rack"
-SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend "virtual/ruby-ssl"
-
-# The gem has automagic dependencies over mongrel, ruby-openid,
-# memcache-client, thin, mongrel and camping; not sure if we should
-# make them dependencies at all. We do add the fcgi dependency because
-# that spec isn't optional.
-ruby_add_bdepend "test? ( dev-ruby/bacon dev-ruby/ruby-fcgi )"
-
-# Block against versions in older slots that also try to install a binary.
-RDEPEND="${RDEPEND} !<dev-ruby/rack-1.1.0-r1:0"
-
-#USE_RUBY=ruby19 \
-# ruby_add_bdepend "ruby_targets_ruby19 test" '=dev-ruby/test-unit-1*'
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${PN}-1.2.1-gentoo.patch
-}
-
-each_ruby_test() {
- # Since the Rakefile calls specrb directly rather than loading it, we
- # cannot use it to launch the tests or only the currently-selected
- # RUBY interpreter will be tested.
- ${RUBY} -S bacon -Ilib -w -a \
- -q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|rackup)' \
- || die "test failed for ${RUBY}"
-}
diff --git a/dev-ruby/rack/rack-1.2.4.ebuild b/dev-ruby/rack/rack-1.2.4.ebuild
deleted file mode 100644
index 197cf5c6bd1a..000000000000
--- a/dev-ruby/rack/rack-1.2.4.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.2.4.ebuild,v 1.2 2011/12/04 19:03:22 graaff Exp $
-
-EAPI="2"
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="ChangeLog KNOWN-ISSUES README SPEC"
-
-inherit ruby-fakegem eutils versionator
-
-DESCRIPTION="A modular Ruby webserver interface"
-HOMEPAGE="https://github.com/rack/rack"
-SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend "virtual/ruby-ssl"
-
-# The gem has automagic dependencies over mongrel, ruby-openid,
-# memcache-client, thin, mongrel and camping; not sure if we should
-# make them dependencies at all. We do add the fcgi dependency because
-# that spec isn't optional.
-ruby_add_bdepend "test? ( dev-ruby/bacon dev-ruby/ruby-fcgi )"
-
-# Block against versions in older slots that also try to install a binary.
-RDEPEND="${RDEPEND} !<dev-ruby/rack-1.1.0-r1:0"
-
-#USE_RUBY=ruby19 \
-# ruby_add_bdepend "ruby_targets_ruby19 test" '=dev-ruby/test-unit-1*'
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${PN}-1.2.1-gentoo.patch
-}
-
-each_ruby_test() {
- # Since the Rakefile calls specrb directly rather than loading it, we
- # cannot use it to launch the tests or only the currently-selected
- # RUBY interpreter will be tested.
- ${RUBY} -S bacon -Ilib -w -a \
- -q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|rackup)' \
- || die "test failed for ${RUBY}"
-}
diff --git a/dev-ruby/rack/rack-1.3.5.ebuild b/dev-ruby/rack/rack-1.3.5.ebuild
deleted file mode 100644
index 9c16bcf0203f..000000000000
--- a/dev-ruby/rack/rack-1.3.5.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.3.5.ebuild,v 1.1 2011/12/24 08:03:02 graaff Exp $
-
-EAPI="2"
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="ChangeLog KNOWN-ISSUES README.rdoc SPEC"
-
-inherit ruby-fakegem eutils versionator
-
-DESCRIPTION="A modular Ruby webserver interface"
-HOMEPAGE="http://rubyforge.org/projects/rack"
-SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend "virtual/ruby-ssl"
-
-# The gem has automagic dependencies over mongrel, ruby-openid,
-# memcache-client, thin, mongrel and camping; not sure if we should
-# make them dependencies at all. We do add the fcgi dependency because
-# that spec isn't optional.
-ruby_add_bdepend "test? ( dev-ruby/bacon dev-ruby/ruby-fcgi )"
-
-# Block against versions in older slots that also try to install a binary.
-RDEPEND="${RDEPEND} !<dev-ruby/rack-1.1.0-r1:0 !<dev-ruby/rack-1.2.4-r2:1.2"
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${PN}-1.2.1-gentoo.patch
-}
-
-each_ruby_prepare() {
- case ${RUBY} in
- *jruby)
- # Avoid two failing tests due to bugs in jruby that should
- # be solved in 1.6.5 or 1.7.
- rm test/spec_deflater.rb || die
- ;;
- *)
- ;;
- esac
-}
-
-each_ruby_test() {
- # Since the Rakefile calls specrb directly rather than loading it, we
- # cannot use it to launch the tests or only the currently-selected
- # RUBY interpreter will be tested.
- ${RUBY} -S bacon -Ilib -w -a \
- -q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Server)' \
- || die "test failed for ${RUBY}"
-}