summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-04-04 11:52:41 +0000
committerHans de Graaff <graaff@gentoo.org>2012-04-04 11:52:41 +0000
commit0da654b6bfa09375767e419e45e82870dda545d0 (patch)
treef82f81499b4f756b733086b893762bf341a80cf1 /dev-ruby/rails
parentRevision bump to include inspircd moving to github.com, fixes to problems (diff)
downloadgentoo-2-0da654b6bfa09375767e419e45e82870dda545d0.tar.gz
gentoo-2-0da654b6bfa09375767e419e45e82870dda545d0.tar.bz2
gentoo-2-0da654b6bfa09375767e419e45e82870dda545d0.zip
Version bump for Rails 3.1.4, security bug 406547.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rails')
-rw-r--r--dev-ruby/rails/ChangeLog7
-rw-r--r--dev-ruby/rails/rails-3.1.4.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index 63b0514cc7cc..93619611bb7c 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.214 2012/04/04 09:59:57 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.215 2012/04/04 11:52:41 graaff Exp $
+
+*rails-3.1.4 (04 Apr 2012)
+
+ 04 Apr 2012; Hans de Graaff <graaff@gentoo.org> +rails-3.1.4.ebuild:
+ Version bump for Rails 3.1.4, security bug 406547.
*rails-3.0.12 (04 Apr 2012)
diff --git a/dev-ruby/rails/rails-3.1.4.ebuild b/dev-ruby/rails/rails-3.1.4.ebuild
new file mode 100644
index 000000000000..6c722ff230c9
--- /dev/null
+++ b/dev-ruby/rails/rails-3.1.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-3.1.4.ebuild,v 1.1 2012/04/04 11:52:41 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="3.1"
+KEYWORDS="~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="+asset-pipeline"
+
+RDEPEND=">=app-admin/eselect-rails-0.18"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionmailer-${PV}
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activeresource-${PV}
+ ~dev-ruby/activesupport-${PV}
+ =dev-ruby/bundler-1*
+ ~dev-ruby/railties-${PV}
+ asset-pipeline? (
+ dev-ruby/jquery-rails
+ dev-ruby/sass-rails
+ dev-ruby/uglifier
+ dev-ruby/coffee-rails
+ )"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rails rails-${PV}
+}
+
+pkg_postinst() {
+ elog "To select between slots of rails, use:"
+ elog "\teselect rails"
+
+ eselect rails update
+}
+
+pkg_postrm() {
+ eselect rails update
+}