summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-09-25 22:48:20 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-09-25 22:48:20 +0000
commita8e4265cba4b7e1c5522b3e04938633d8711dc4a (patch)
tree559230cd0418bda61717f419f376dafd9a4d8338 /dev-ruby/redcloth
parentVersion bump (diff)
downloadgentoo-2-a8e4265cba4b7e1c5522b3e04938633d8711dc4a.tar.gz
gentoo-2-a8e4265cba4b7e1c5522b3e04938633d8711dc4a.tar.bz2
gentoo-2-a8e4265cba4b7e1c5522b3e04938633d8711dc4a.zip
Version bump; this version does not require patches (yuppie).
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/redcloth')
-rw-r--r--dev-ruby/redcloth/ChangeLog7
-rw-r--r--dev-ruby/redcloth/redcloth-4.2.8.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/dev-ruby/redcloth/ChangeLog b/dev-ruby/redcloth/ChangeLog
index a01c0b7cbe5b..4668a14badbd 100644
--- a/dev-ruby/redcloth/ChangeLog
+++ b/dev-ruby/redcloth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/redcloth
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/ChangeLog,v 1.61 2011/07/22 13:07:41 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/ChangeLog,v 1.62 2011/09/25 22:48:20 flameeyes Exp $
+
+*redcloth-4.2.8 (25 Sep 2011)
+
+ 25 Sep 2011; Diego E. Pettenò <flameeyes@gentoo.org> +redcloth-4.2.8.ebuild:
+ Version bump; this version does not require patches (yuppie).
22 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> redcloth-4.2.3-r1.ebuild:
ppc64 stable wrt #352483
diff --git a/dev-ruby/redcloth/redcloth-4.2.8.ebuild b/dev-ruby/redcloth/redcloth-4.2.8.ebuild
new file mode 100644
index 000000000000..389f68482136
--- /dev/null
+++ b/dev-ruby/redcloth/redcloth-4.2.8.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/redcloth-4.2.8.ebuild,v 1.1 2011/09/25 22:48:20 flameeyes Exp $
+
+EAPI=4
+
+# jruby → tests still fail with UTF-8 characters
+# http://jgarber.lighthouseapp.com/projects/13054/tickets/149-redcloth-4-doesnt-support-multi-bytes-content
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_NAME="RedCloth"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGELOG"
+
+RUBY_FAKEGEM_REQUIRE_PATHS="lib/case_sensitive_require"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A module for using Textile in Ruby"
+HOMEPAGE="http://redcloth.org/"
+
+GITHUB_USER=jgarber
+SRC_URI="https://github.com/${GITHUB_USER}/redcloth/tarball/v${PV} -> ${RUBY_FAKEGEM_NAME}-git-${PV}.tgz"
+RUBY_S="${GITHUB_USER}-${PN}-*"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+DEPEND="$DEPEND
+ dev-util/ragel"
+RDEPEND="$RDEPEND"
+
+ruby_add_bdepend "
+ >=dev-ruby/rake-0.8.7
+ >=dev-ruby/rake-compiler-0.7.1
+ test? (
+ >=dev-ruby/rspec-2.4
+ >=dev-ruby/diff-lcs-1.1.2
+ )"
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+
+ # Export the VERBOSE variable to avoid remapping of stdout and
+ # stderr, and that breaks because of bad interactions between
+ # echoe, Ruby and Gentoo.
+ export VERBOSE=1
+}
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile ${PN}.gemspec || die
+ rm tasks/{release,gems}.rake || die
+}
+
+each_ruby_compile() {
+ # We cannot run this manually easily, because Ragel re-generation
+ # is a mess
+ ${RUBY} -S rake compile || die "rake compile failed"
+}
+
+each_ruby_test() {
+ find spec -name '*_spec.rb' -print0 | xargs -0 ${RUBY} -I lib -S rspec -Du -fs
+}