summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-28 08:20:13 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-28 08:20:13 +0000
commit29c90e6d02310331810cf4d51fc31d15f2736b34 (patch)
tree007499959c578ef03b1549b6d43da4e617469ea2 /dev-ruby/rspec-mocks
parentDrop ruby19 from stable version. (diff)
downloadgentoo-2-29c90e6d02310331810cf4d51fc31d15f2736b34.tar.gz
gentoo-2-29c90e6d02310331810cf4d51fc31d15f2736b34.tar.bz2
gentoo-2-29c90e6d02310331810cf4d51fc31d15f2736b34.zip
Revision bump to drop ruby19 from stable version.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rspec-mocks')
-rw-r--r--dev-ruby/rspec-mocks/ChangeLog8
-rw-r--r--dev-ruby/rspec-mocks/rspec-mocks-2.6.0-r1.ebuild61
-rw-r--r--dev-ruby/rspec-mocks/rspec-mocks-2.6.0.ebuild4
3 files changed, 70 insertions, 3 deletions
diff --git a/dev-ruby/rspec-mocks/ChangeLog b/dev-ruby/rspec-mocks/ChangeLog
index d4273961bb76..ff4a9fe403a1 100644
--- a/dev-ruby/rspec-mocks/ChangeLog
+++ b/dev-ruby/rspec-mocks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rspec-mocks
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/ChangeLog,v 1.19 2011/10/02 17:01:25 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/ChangeLog,v 1.20 2011/12/28 08:20:13 graaff Exp $
+
+*rspec-mocks-2.6.0-r1 (28 Dec 2011)
+
+ 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> rspec-mocks-2.6.0.ebuild,
+ +rspec-mocks-2.6.0-r1.ebuild:
+ Revision bump to drop ruby19 from stable version.
02 Oct 2011; Raúl Porcel <armin76@gentoo.org> rspec-mocks-2.6.0.ebuild:
ia64/sparc stable wrt #369573
diff --git a/dev-ruby/rspec-mocks/rspec-mocks-2.6.0-r1.ebuild b/dev-ruby/rspec-mocks/rspec-mocks-2.6.0-r1.ebuild
new file mode 100644
index 000000000000..00397e2ec8c6
--- /dev/null
+++ b/dev-ruby/rspec-mocks/rspec-mocks-2.6.0-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/rspec-mocks-2.6.0-r1.ebuild,v 1.1 2011/12/28 08:20:13 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# cucumber and rspec-core are loaded unconditionally in the Rakefile,
+# so we also need to require them for USE=doc.
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-core-2.6.0:2
+ dev-ruby/rspec-expectations:2
+ )
+ doc? ( dev-ruby/rspec-core:2 )"
+
+# Not clear yet to what extend we need those (now)
+# >=dev-ruby/cucumber-0.6.2
+# >=dev-ruby/aruba-0.1.1"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+}
+
+all_ruby_compile() {
+ if use doc ; then
+ RUBYLIB="${S}/lib" rake rdoc || die
+ fi
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ # This particular failure is reported to be fixed in jruby 1.6.
+ ewarn "Tests disabled because they crash jruby."
+ ;;
+ *)
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -S rake spec || die
+ ;;
+ esac
+
+ # There are features but they require aruba which we don't have yet.
+}
diff --git a/dev-ruby/rspec-mocks/rspec-mocks-2.6.0.ebuild b/dev-ruby/rspec-mocks/rspec-mocks-2.6.0.ebuild
index 5e014eca07ef..abf98587a6d3 100644
--- a/dev-ruby/rspec-mocks/rspec-mocks-2.6.0.ebuild
+++ b/dev-ruby/rspec-mocks/rspec-mocks-2.6.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/rspec-mocks-2.6.0.ebuild,v 1.8 2011/10/02 17:01:25 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/rspec-mocks-2.6.0.ebuild,v 1.9 2011/12/28 08:20:13 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ree18 ruby19 jruby"
+USE_RUBY="ruby18 ree18 jruby"
RUBY_FAKEGEM_TASK_TEST="none"