summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-09-13 18:03:15 +0000
committerHans de Graaff <graaff@gentoo.org>2010-09-13 18:03:15 +0000
commit576c5a502e10093bf5eb0fff0dc6243cde7b8455 (patch)
tree50e2426552b5badcc3eab39f440570042ce91ce7 /dev-ruby/rspec-mocks
parentInitial import of rspec-2. (diff)
downloadgentoo-2-576c5a502e10093bf5eb0fff0dc6243cde7b8455.tar.gz
gentoo-2-576c5a502e10093bf5eb0fff0dc6243cde7b8455.tar.bz2
gentoo-2-576c5a502e10093bf5eb0fff0dc6243cde7b8455.zip
Initial import of rspec-2.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rspec-mocks')
-rw-r--r--dev-ruby/rspec-mocks/ChangeLog10
-rw-r--r--dev-ruby/rspec-mocks/metadata.xml5
-rw-r--r--dev-ruby/rspec-mocks/rspec-mocks-2.0.0_beta22.ebuild56
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-ruby/rspec-mocks/ChangeLog b/dev-ruby/rspec-mocks/ChangeLog
new file mode 100644
index 000000000000..b71b31e6419d
--- /dev/null
+++ b/dev-ruby/rspec-mocks/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/rspec-mocks
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/ChangeLog,v 1.1 2010/09/13 18:03:15 graaff Exp $
+
+*rspec-mocks-2.0.0_beta22 (13 Sep 2010)
+
+ 13 Sep 2010; Hans de Graaff <graaff@gentoo.org>
+ +rspec-mocks-2.0.0_beta22.ebuild, +metadata.xml:
+ Initial import of rspec-2.
+
diff --git a/dev-ruby/rspec-mocks/metadata.xml b/dev-ruby/rspec-mocks/metadata.xml
new file mode 100644
index 000000000000..0040b1162894
--- /dev/null
+++ b/dev-ruby/rspec-mocks/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/rspec-mocks/rspec-mocks-2.0.0_beta22.ebuild b/dev-ruby/rspec-mocks/rspec-mocks-2.0.0_beta22.ebuild
new file mode 100644
index 000000000000..f4fa2e7d9475
--- /dev/null
+++ b/dev-ruby/rspec-mocks/rspec-mocks-2.0.0_beta22.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/rspec-mocks-2.0.0_beta22.ebuild,v 1.1 2010/09/13 18:03:15 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+RUBY_FAKEGEM_VERSION="2.0.0.beta.22"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+SRC_URI="mirror://rubygems/${PN}-${RUBY_FAKEGEM_VERSION}.gem"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+# cucumber and rspec-core are loaded unconditionally in the Rakefile,
+# so we also need to require them for USE=doc.
+ruby_add_bdepend "test? (
+ ~dev-ruby/rspec-core-${PV}
+ ~dev-ruby/rspec-expectations-${PV}
+ dev-util/cucumber
+ )
+ doc? ( ~dev-ruby/rspec-core-${PV} dev-util/cucumber )"
+
+# Not clear yet to what extend we need those (now)
+# >=dev-ruby/cucumber-0.6.2
+# >=dev-ruby/aruba-0.1.1"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e "s|require 'bundler'|require 'rspec/mocks/version'|" Rakefile || die
+ sed -i -e '/Bundler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+}
+
+all_ruby_compile() {
+ RUBYLIB="${S}/lib" rake rdoc || die
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -S rake spec || die
+
+ # There are features but they require aruba which we don't have yet.
+}