summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-04-24 19:27:56 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-04-24 19:27:56 +0000
commita236ec970eeef332630eae67e89e751eb0257b9f (patch)
tree1b985ecc63d66d561f39e961a0ef994e0e8fb57f /dev-ruby/ruby-dbi
parentFixes #2059. (diff)
downloadgentoo-2-a236ec970eeef332630eae67e89e751eb0257b9f.tar.gz
gentoo-2-a236ec970eeef332630eae67e89e751eb0257b9f.tar.bz2
gentoo-2-a236ec970eeef332630eae67e89e751eb0257b9f.zip
Fixes #1883.
Diffstat (limited to 'dev-ruby/ruby-dbi')
-rw-r--r--dev-ruby/ruby-dbi/ChangeLog12
-rw-r--r--dev-ruby/ruby-dbi/files/digest-ruby-dbi-0.0.131
-rw-r--r--dev-ruby/ruby-dbi/ruby-dbi-0.0.13.ebuild43
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-ruby/ruby-dbi/ChangeLog b/dev-ruby/ruby-dbi/ChangeLog
new file mode 100644
index 000000000000..6e4d68f36452
--- /dev/null
+++ b/dev-ruby/ruby-dbi/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-ruby/ruby-dbi
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-dbi/ChangeLog,v 1.1 2002/04/24 19:27:56 karltk Exp $
+
+*ruby-dbi-0.0.13 (24 Apr 2002)
+
+ 24 Apr 2002; Karl Trygve Kalleberg <karltk@gentoo.org> ruby-dbi-0.0.13.ebuild files/digest-ruby-dbi-0.0.13 :
+
+ Ruby/DBI - a database independent interface for accessing databases -
+ similar to Perl's DBI.
+
+ Ebuild submitted by Geert Bevin <gbevin@uwyn.com>.
diff --git a/dev-ruby/ruby-dbi/files/digest-ruby-dbi-0.0.13 b/dev-ruby/ruby-dbi/files/digest-ruby-dbi-0.0.13
new file mode 100644
index 000000000000..f3d6f9115895
--- /dev/null
+++ b/dev-ruby/ruby-dbi/files/digest-ruby-dbi-0.0.13
@@ -0,0 +1 @@
+MD5 dc1a87b7cd6a2dca1560cc1d0d6091ad ruby-dbi-all-0.0.13.tar.gz 85463
diff --git a/dev-ruby/ruby-dbi/ruby-dbi-0.0.13.ebuild b/dev-ruby/ruby-dbi/ruby-dbi-0.0.13.ebuild
new file mode 100644
index 000000000000..979a722138f6
--- /dev/null
+++ b/dev-ruby/ruby-dbi/ruby-dbi-0.0.13.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Geert Bevin <gbevin@uwyn.com>
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-dbi/ruby-dbi-0.0.13.ebuild,v 1.1 2002/04/24 19:27:56 karltk Exp $
+
+S=${WORKDIR}/ruby-dbi-all
+DESCRIPTION="Ruby/DBI - a database independent interface for accessing databases - similar to Perl's DBI"
+SRC_URI="http://prdownloads.sourceforge.net/ruby-dbi/ruby-dbi-all-${PV}.tar.gz"
+HOMEPAGE="http://ruby-dbi.sourceforge.net/"
+
+DEPEND="=dev-lang/ruby-1.6*
+ mysql? (>=dev-db/mysql-3.23.49)
+ postgres? (>=dev-db/postgresql-7.1.3-r4)
+ firebird? (>=dev-db/firebird-1.0-r1)
+ odbc? (>=dev-db/unixODBC-2.0.6)"
+
+src_compile() {
+
+ my_config="dbi,dbd_proxy,dbd_sqlrelay"
+ use mysql && my_config="$my_config,dbd_mysql"
+ use postgres && my_config="$my_config,dbd_pg"
+ use firebird && my_config="$my_config,dbd_interbase"
+ use odbc && my_config="$my_config,dbd_odbc"
+
+ ruby setup.rb config --with=$my_config \
+ --bin-dir="${D}/usr/bin" \
+ --rb-dir="${D}/usr/lib/ruby/site_ruby/1.6" \
+ --so-dir="${D}/usr/lib/ruby/site_ruby/1.6/i686-linux-gnu" || die
+ ruby setup.rb setup || die
+
+}
+
+src_install () {
+
+ dodir /usr/bin
+ dodir /usr/lib/ruby/site_ruby/1.6
+ dodir /usr/lib/ruby/site_ruby/1.6/i686-linux-gnu
+
+ ruby setup.rb install || die
+
+ dodoc LICENSE README
+}
+