summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2005-11-01 14:35:45 +0000
committerCaleb Tennis <caleb@gentoo.org>2005-11-01 14:35:45 +0000
commit33103abed3fa165d7c467a6c6df97d6e9432b359 (patch)
treed78fec0df482a133c16b88382bebb7ab7feeb046 /dev-ruby/ruby-gd
parentClean-ups in gnumeric-1.6.0.ebuild (diff)
downloadgentoo-2-33103abed3fa165d7c467a6c6df97d6e9432b359.tar.gz
gentoo-2-33103abed3fa165d7c467a6c6df97d6e9432b359.tar.bz2
gentoo-2-33103abed3fa165d7c467a6c6df97d6e9432b359.zip
Make X dep options - bug #109289
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'dev-ruby/ruby-gd')
-rw-r--r--dev-ruby/ruby-gd/ChangeLog7
-rw-r--r--dev-ruby/ruby-gd/ruby-gd-0.7.4.ebuild14
2 files changed, 14 insertions, 7 deletions
diff --git a/dev-ruby/ruby-gd/ChangeLog b/dev-ruby/ruby-gd/ChangeLog
index 8cffc1c25469..2002ed771b43 100644
--- a/dev-ruby/ruby-gd/ChangeLog
+++ b/dev-ruby/ruby-gd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/ruby-gd
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gd/ChangeLog,v 1.4 2004/12/18 09:47:24 corsair Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gd/ChangeLog,v 1.5 2005/11/01 14:35:45 caleb Exp $
+
+ 01 Nov 2005; Caleb Tennis <caleb@gentoo.org> ruby-gd-0.7.4.ebuild:
+ Making X dep optional - bug #109289
16 Dec 2004; Markus Rothe <corsair@gentoo.org> ruby-gd-0.7.4.ebuild:
Stable on ppc64
diff --git a/dev-ruby/ruby-gd/ruby-gd-0.7.4.ebuild b/dev-ruby/ruby-gd/ruby-gd-0.7.4.ebuild
index 77c93c8709a3..15a9cb5de8c7 100644
--- a/dev-ruby/ruby-gd/ruby-gd-0.7.4.ebuild
+++ b/dev-ruby/ruby-gd/ruby-gd-0.7.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gd/ruby-gd-0.7.4.ebuild,v 1.5 2004/12/18 09:47:24 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gd/ruby-gd-0.7.4.ebuild,v 1.6 2005/11/01 14:35:45 caleb Exp $
inherit ruby
USE_RUBY="ruby16 ruby18 ruby19"
@@ -15,18 +15,22 @@ SRC_URI="http://tam.0xfa.com/ruby-gd/${MY_P}-1.tar.gz"
LICENSE="Ruby"
SLOT="0"
KEYWORDS="~x86 ppc64"
-IUSE="jpeg truetype"
+IUSE="jpeg truetype X"
DEPEND="virtual/ruby
- virtual/x11
>=media-libs/gd-2.0
jpeg? ( media-libs/jpeg )
- truetype? ( media-libs/freetype )"
+ truetype? ( media-libs/freetype )
+ X? ( virtual/x11 )"
src_compile() {
local myconf=""
myconf="${myconf} --enable-gd2_0 --with-xpm"
+ if use X; then
+ myconf="${myconf} --with-xpm"
+ fi
+
if use jpeg; then
myconf="${myconf} --with-jpeg"
fi