summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-08-08 17:55:03 +0000
committerHans de Graaff <graaff@gentoo.org>2010-08-08 17:55:03 +0000
commit25c1e3b3091a0484a94ec8da14f71c5d81b41455 (patch)
tree25afa322befa00880b0c489ceb7a30adfc284695 /dev-ruby/ruby-prof
parentFixed Typo (diff)
downloadgentoo-2-25c1e3b3091a0484a94ec8da14f71c5d81b41455.tar.gz
gentoo-2-25c1e3b3091a0484a94ec8da14f71c5d81b41455.tar.bz2
gentoo-2-25c1e3b3091a0484a94ec8da14f71c5d81b41455.zip
Remove old versions.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-prof')
-rw-r--r--dev-ruby/ruby-prof/ChangeLog6
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.7.10.ebuild56
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.8.1.ebuild66
3 files changed, 5 insertions, 123 deletions
diff --git a/dev-ruby/ruby-prof/ChangeLog b/dev-ruby/ruby-prof/ChangeLog
index 763830ccaa75..47f68f0fb601 100644
--- a/dev-ruby/ruby-prof/ChangeLog
+++ b/dev-ruby/ruby-prof/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/ruby-prof
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.25 2010/07/12 06:03:56 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.26 2010/08/08 17:55:03 graaff Exp $
+
+ 08 Aug 2010; Hans de Graaff <graaff@gentoo.org> -ruby-prof-0.7.10.ebuild,
+ -ruby-prof-0.8.1.ebuild:
+ Remove old versions.
*ruby-prof-0.8.2 (12 Jul 2010)
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.7.10.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.7.10.ebuild
deleted file mode 100644
index b1bed9c42dbe..000000000000
--- a/dev-ruby/ruby-prof/ruby-prof-0.7.10.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ruby-prof-0.7.10.ebuild,v 1.2 2010/05/22 15:53:19 flameeyes Exp $
-
-EAPI=2
-
-# jruby → not compatible, since it uses an extension
-USE_RUBY="ruby18 ruby19"
-
-RUBY_FAKEGEM_EXTRADOC="README CHANGES"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A module for profiling Ruby code"
-HOMEPAGE="http://rubyforge.org/projects/ruby-prof/"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
-
-all_ruby_prepare() {
- # The thread testing in 0.7.5 and earlier versions is broken, it
- # has to be tested for the next versions, since upstream is
- # looking for a solution. The problem is that it's _very_
- # timing-dependent.
- rm "${S}"/test/thread_test.rb \
- || die "unable to remove broken test unit"
- sed -i -e '/thread_test/d' \
- test/test_suite.rb || die "unable to remove broken test reference"
- sed -i -e 's:\./prime:prime:' \
- test/printers_test.rb || die "unable to fix broken test"
-}
-
-each_ruby_compile() {
- pushd ext
- ${RUBY} extconf.rb || die "extconf.rb failed"
- # gem ships with prebuild files
- emake clean || die "clean failed"
- emake || die "build failed"
- popd
-
- cp ext/*.so lib || die "copy of extension failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- for dir in examples rails rails/example rails/environment; do
- docinto "$dir"
- dodoc "$dir"/* || die "dodoc $dir failed"
- done
-}
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.8.1.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.8.1.ebuild
deleted file mode 100644
index 6cab20a65a19..000000000000
--- a/dev-ruby/ruby-prof/ruby-prof-0.8.1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ruby-prof-0.8.1.ebuild,v 1.2 2010/05/22 15:53:19 flameeyes Exp $
-
-EAPI=2
-
-# jruby → not compatible, since it uses an extension
-USE_RUBY="ruby18 ruby19"
-
-RUBY_FAKEGEM_EXTRADOC="README CHANGES"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A module for profiling Ruby code"
-HOMEPAGE="http://rubyforge.org/projects/ruby-prof/"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
-
-all_ruby_prepare() {
- # The thread testing in 0.8.1 and earlier versions is broken, it
- # has to be tested for the next versions, since upstream is
- # looking for a solution. The problem is that it's _very_
- # timing-dependent.
- rm "${S}"/test/thread_test.rb \
- || die "unable to remove broken test unit"
- sed -i -e '/thread_test/d' \
- test/test_suite.rb || die "unable to remove broken test reference"
-}
-
-each_ruby_prepare() {
- case ${RUBY} in
- *ruby19)
- # On ruby 1.9 this test fails badly, so we disable it
- # until upstream can fix the related bug:
- # http://redmine.ruby-lang.org/issues/show/2012
- sed -i -e '/^ def test_flat_string_with_numbers/,/^ end/ s:^:#:' \
- test/printers_test.rb || die "Unable to disable test_flat_string_with_numbers"
- ;;
- esac
-}
-
-each_ruby_compile() {
- pushd ext
- ${RUBY} extconf.rb || die "extconf.rb failed"
- # gem ships with prebuild files
- emake clean || die "clean failed"
- emake || die "build failed"
- popd
-
- cp ext/*.so lib || die "copy of extension failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- for dir in examples rails rails/example rails/environment; do
- docinto "$dir"
- dodoc "$dir"/* || die "dodoc $dir failed"
- done
-}