summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-23 00:40:24 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-23 00:40:24 +0000
commita0cc94771734153997db7ca99b840e05e533caac (patch)
tree635769ef6423a52ed38e32298deaf269d9375d57 /dev-ruby/ruby-prof
parentVersion bump. Fixes bug #298270 reported by Arfrever. (diff)
downloadgentoo-2-a0cc94771734153997db7ca99b840e05e533caac.tar.gz
gentoo-2-a0cc94771734153997db7ca99b840e05e533caac.tar.bz2
gentoo-2-a0cc94771734153997db7ca99b840e05e533caac.zip
Version bump, one further fix is needed to the testsuite for it to work.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-prof')
-rw-r--r--dev-ruby/ruby-prof/ChangeLog8
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.7.10.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-ruby/ruby-prof/ChangeLog b/dev-ruby/ruby-prof/ChangeLog
index 0d195f4ad13f..7db2a1597e20 100644
--- a/dev-ruby/ruby-prof/ChangeLog
+++ b/dev-ruby/ruby-prof/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/ruby-prof
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.20 2010/01/16 13:42:08 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.21 2010/01/23 00:40:24 flameeyes Exp $
+
+*ruby-prof-0.7.10 (23 Jan 2010)
+
+ 23 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +ruby-prof-0.7.10.ebuild:
+ Version bump, one further fix is needed to the testsuite for it to work.
*ruby-prof-0.7.9 (16 Jan 2010)
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.7.10.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.7.10.ebuild
new file mode 100644
index 000000000000..d1fd772d95e5
--- /dev/null
+++ b/dev-ruby/ruby-prof/ruby-prof-0.7.10.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ruby-prof-0.7.10.ebuild,v 1.1 2010/01/23 00:40:24 flameeyes Exp $
+
+EAPI=2
+
+# jruby → not compatible, since it uses an extension
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_EXTRADOC="README CHANGES"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A module for profiling Ruby code"
+HOMEPAGE="http://rubyforge.org/projects/ruby-prof/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_bdepend test virtual/ruby-test-unit
+
+all_ruby_prepare() {
+ # The thread testing in 0.7.5 and earlier versions is broken, it
+ # has to be tested for the next versions, since upstream is
+ # looking for a solution. The problem is that it's _very_
+ # timing-dependent.
+ rm "${S}"/test/thread_test.rb \
+ || die "unable to remove broken test unit"
+ sed -i -e '/thread_test/d' \
+ test/test_suite.rb || die "unable to remove broken test reference"
+ sed -i -e 's:\./prime:prime:' \
+ test/printers_test.rb || die "unable to fix broken test"
+}
+
+each_ruby_compile() {
+ pushd ext
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+ # gem ships with prebuild files
+ emake clean || die "clean failed"
+ emake || die "build failed"
+ popd
+
+ cp ext/*.so lib || die "copy of extension failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ for dir in examples rails rails/example rails/environment; do
+ docinto "$dir"
+ dodoc "$dir"/* || die "dodoc $dir failed"
+ done
+}