summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-02-27 20:45:24 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-02-27 20:45:24 +0000
commit66d5c105bc1f5d23d22c9867ce01cda21357c768 (patch)
tree3068b9dcc091f667e6c7d60ce3c8013191d60c60 /dev-ruby/syslogger
parentRevision bump to try supporting Ruby 1.9 _or_ Ruby 1.8. (diff)
downloadgentoo-2-66d5c105bc1f5d23d22c9867ce01cda21357c768.tar.gz
gentoo-2-66d5c105bc1f5d23d22c9867ce01cda21357c768.tar.bz2
gentoo-2-66d5c105bc1f5d23d22c9867ce01cda21357c768.zip
Version bump (now uses rspec2, add jruby support); fix SLOT setting.
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/syslogger')
-rw-r--r--dev-ruby/syslogger/ChangeLog8
-rw-r--r--dev-ruby/syslogger/syslogger-1.2.5.ebuild4
-rw-r--r--dev-ruby/syslogger/syslogger-1.2.6.ebuild30
3 files changed, 39 insertions, 3 deletions
diff --git a/dev-ruby/syslogger/ChangeLog b/dev-ruby/syslogger/ChangeLog
index 3bce3983eeaf..0bca1556696c 100644
--- a/dev-ruby/syslogger/ChangeLog
+++ b/dev-ruby/syslogger/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/syslogger
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/syslogger/ChangeLog,v 1.1 2012/01/22 18:45:01 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/syslogger/ChangeLog,v 1.2 2012/02/27 20:45:24 flameeyes Exp $
+
+*syslogger-1.2.6 (27 Feb 2012)
+
+ 27 Feb 2012; Diego E. Pettenò <flameeyes@gentoo.org> +syslogger-1.2.6.ebuild,
+ syslogger-1.2.5.ebuild:
+ Version bump (now uses rspec2, add jruby support); fix SLOT setting.
*syslogger-1.2.5 (22 Jan 2012)
diff --git a/dev-ruby/syslogger/syslogger-1.2.5.ebuild b/dev-ruby/syslogger/syslogger-1.2.5.ebuild
index f9117579ff48..9ace500e7fce 100644
--- a/dev-ruby/syslogger/syslogger-1.2.5.ebuild
+++ b/dev-ruby/syslogger/syslogger-1.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/syslogger/syslogger-1.2.5.ebuild,v 1.1 2012/01/22 18:45:01 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/syslogger/syslogger-1.2.5.ebuild,v 1.2 2012/02/27 20:45:24 flameeyes Exp $
EAPI=4
USE_RUBY="ruby18 ree18 ruby19"
@@ -21,7 +21,7 @@ DESCRIPTION="Drop-in replacement for the standard Logger, that logs to the syslo
HOMEPAGE="https://github.com/crohr/syslogger"
LICENSE="MIT"
-SLOT="3"
+SLOT="0"
KEYWORDS="~amd64"
IUSE=""
diff --git a/dev-ruby/syslogger/syslogger-1.2.6.ebuild b/dev-ruby/syslogger/syslogger-1.2.6.ebuild
new file mode 100644
index 000000000000..bea0dfdc9532
--- /dev/null
+++ b/dev-ruby/syslogger/syslogger-1.2.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/syslogger/syslogger-1.2.6.ebuild,v 1.1 2012/02/27 20:45:24 flameeyes Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+# if ever needed
+#GITHUB_USER="crohr"
+#GITHUB_PROJECT="${PN}"
+#RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Drop-in replacement for the standard Logger, that logs to the syslog"
+HOMEPAGE="https://github.com/crohr/syslogger"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "
+ test? ( dev-ruby/rspec:2 )
+ doc? ( >=dev-ruby/rdoc-2.4.2 )"