summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-06 17:08:12 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-06 17:08:12 +0000
commit01f864b45056892c20f9443de38663d9b2947a03 (patch)
tree36507cc01c040caa2fca6918855cee2a83d7a553 /dev-ruby
parentAdd ruby20 target. (diff)
downloadgentoo-2-01f864b45056892c20f9443de38663d9b2947a03.tar.gz
gentoo-2-01f864b45056892c20f9443de38663d9b2947a03.tar.bz2
gentoo-2-01f864b45056892c20f9443de38663d9b2947a03.zip
Add ruby20 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/coderay/ChangeLog7
-rw-r--r--dev-ruby/coderay/coderay-1.1.0-r1.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-ruby/coderay/ChangeLog b/dev-ruby/coderay/ChangeLog
index 0a14f1d92ff6..286a2d98f121 100644
--- a/dev-ruby/coderay/ChangeLog
+++ b/dev-ruby/coderay/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/coderay
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/ChangeLog,v 1.76 2013/09/04 13:36:43 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/ChangeLog,v 1.77 2013/10/06 17:08:12 mrueg Exp $
+
+*coderay-1.1.0-r1 (06 Oct 2013)
+
+ 06 Oct 2013; Manuel Rüger <mrueg@gentoo.org> +coderay-1.1.0-r1.ebuild:
+ Add ruby20 target.
04 Sep 2013; Manuel Rüger <mrueg@gentoo.org> -coderay-0.9.8.ebuild:
Cleanup old.
diff --git a/dev-ruby/coderay/coderay-1.1.0-r1.ebuild b/dev-ruby/coderay/coderay-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..612e9670cd3e
--- /dev/null
+++ b/dev-ruby/coderay/coderay-1.1.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/coderay-1.1.0-r1.ebuild,v 1.1 2013/10/06 17:08:12 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+# The test target also contains test:exe but that requires
+# shoulda-context which we do not have packaged yet.
+RUBY_FAKEGEM_TASK_TEST="test:functional test:units"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="Changes-pre-1.0.textile Changes.textile FOLDERS README_INDEX.rdoc README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby library for syntax highlighting."
+HOMEPAGE="http://coderay.rubychan.de/"
+SRC_URI="https://github.com/rubychan/coderay/tarball/v${PV} -> ${P}.tgz"
+
+RUBY_S="rubychan-coderay-*"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Redcloth is optional but automagically tested, so we add this
+# dependency to ensure that we get at least a version that works: bug
+# 330621. We use this convoluted way because redcloth isn't available
+# yet for jruby.
+USE_RUBY="${USE_RUBY/jruby/}" ruby_add_bdepend "test? ( >=dev-ruby/redcloth-4.2.2 )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e '/git ls-files/ s:^:#:' coderay.gemspec || die
+}