summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-12-03 07:06:14 +0000
committerHans de Graaff <graaff@gentoo.org>2014-12-03 07:06:14 +0000
commit03ae534af893fe2f4ff53ab71b233aab5c24ff48 (patch)
tree24ef99b236ece4bc0e345acf6d7eec67355f328f /dev-ruby
parentApply cross-compile fix (bug #521446 by James Le Cuirot). (diff)
downloadgentoo-2-03ae534af893fe2f4ff53ab71b233aab5c24ff48.tar.gz
gentoo-2-03ae534af893fe2f4ff53ab71b233aab5c24ff48.tar.bz2
gentoo-2-03ae534af893fe2f4ff53ab71b233aab5c24ff48.zip
Version bump.
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/nokogiri/ChangeLog7
-rw-r--r--dev-ruby/nokogiri/nokogiri-1.6.5.ebuild81
2 files changed, 87 insertions, 1 deletions
diff --git a/dev-ruby/nokogiri/ChangeLog b/dev-ruby/nokogiri/ChangeLog
index 7b6a2ee492ea..93d19128dd2a 100644
--- a/dev-ruby/nokogiri/ChangeLog
+++ b/dev-ruby/nokogiri/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/nokogiri
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/ChangeLog,v 1.112 2014/11/25 13:10:25 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/ChangeLog,v 1.113 2014/12/03 07:06:14 graaff Exp $
+
+*nokogiri-1.6.5 (03 Dec 2014)
+
+ 03 Dec 2014; Hans de Graaff <graaff@gentoo.org> +nokogiri-1.6.5.ebuild:
+ Version bump.
25 Nov 2014; Manuel Rüger <mrueg@gentoo.org> nokogiri-1.5.10.ebuild,
nokogiri-1.6.0.ebuild, nokogiri-1.6.3.1.ebuild:
diff --git a/dev-ruby/nokogiri/nokogiri-1.6.5.ebuild b/dev-ruby/nokogiri/nokogiri-1.6.5.ebuild
new file mode 100644
index 000000000000..202c2aa1ba32
--- /dev/null
+++ b/dev-ruby/nokogiri/nokogiri-1.6.5.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/nokogiri-1.6.5.ebuild,v 1.1 2014/12/03 07:06:14 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc CHANGELOG.ja.rdoc README.rdoc README.ja.rdoc ROADMAP.md STANDARD_RESPONSES.md"
+
+inherit ruby-fakegem eutils multilib
+
+DESCRIPTION="Nokogiri is an HTML, XML, SAX, and Reader parser"
+HOMEPAGE="http://nokogiri.org/"
+LICENSE="MIT"
+SRC_URI="https://github.com/sparklemotion/nokogiri/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${RDEPEND}
+ >=dev-libs/libxml2-2.9.2:=
+ dev-libs/libxslt
+ virtual/libiconv"
+DEPEND="${DEPEND}
+ >=dev-libs/libxml2-2.9.2
+ dev-libs/libxslt
+ virtual/libiconv"
+
+# The tests require _minitest_, not the virtual; what is shipped with
+# Ruby 1.9 is *not* enough, unfortunately
+ruby_add_bdepend "
+ dev-ruby/hoe
+ dev-ruby/rake-compiler
+ dev-ruby/rexical
+ dev-ruby/rdoc
+ dev-ruby/racc
+ test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/tasks\/cross_compile/s:^:#:' \
+ -e '/:test.*prerequisites/s:^:#:' \
+ Rakefile || die
+ # Remove the cross compilation options since they interfere with
+ # native building.
+ sed -i -e 's/cross_compile = true/cross_compile = false/' Rakefile || die
+ sed -i -e '/cross_config_options/d' Rakefile || die
+}
+
+each_ruby_configure() {
+ NOKOGIRI_USE_SYSTEM_LIBRARIES=true \
+ ${RUBY} -Cext/${PN} extconf.rb \
+ --with-zlib-include="${EPREFIX}"/usr/include \
+ --with-zlib-lib="${EPREFIX}"/$(get_libdir) \
+ --with-iconv-include="${EPREFIX}"/usr/include \
+ --with-iconv-lib="${EPREFIX}"/$(get_libdir) \
+ --with-xml2-include="${EPREFIX}"/usr/include/libxml2 \
+ --with-xml2-lib="${EPREFIX}"/usr/$(get_libdir) \
+ --with-xslt-dir="${EPREFIX}"/usr \
+ --with-iconvlib=iconv \
+ || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ if ! [[ -f lib/nokogiri/css/tokenizer.rb ]]; then
+ ${RUBY} -S rake lib/nokogiri/css/tokenizer.rb || die "rexical failed"
+ fi
+
+ if ! [[ -f lib/nokogiri/css/parser.rb ]]; then
+ ${RUBY} -S rake lib/nokogiri/css/parser.rb || die "racc failed"
+ fi
+
+ emake -Cext/${PN} \
+ V=1 \
+ CFLAGS="${CFLAGS} -fPIC" \
+ archflag="${LDFLAGS}" || die "make extension failed"
+ cp -l ext/${PN}/${PN}$(get_modname) lib/${PN}/ || die
+}