summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-03-10 23:01:11 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-03-10 23:01:11 +0000
commit06c8041c4be0caa20352a087bacfdc54c6ec5616 (patch)
tree96e127ad0e48cb281bf9f082efff69ade6b843dc /dev-ruby
parentnew version; removed older buggy stuff (diff)
downloadgentoo-2-06c8041c4be0caa20352a087bacfdc54c6ec5616.tar.gz
gentoo-2-06c8041c4be0caa20352a087bacfdc54c6ec5616.tar.bz2
gentoo-2-06c8041c4be0caa20352a087bacfdc54c6ec5616.zip
Added mod-ruby-0.9.7, untested, masked
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/mod-ruby/ChangeLog13
-rw-r--r--dev-ruby/mod-ruby/files/digest-mod-ruby-0.9.71
-rw-r--r--dev-ruby/mod-ruby/mod-ruby-0.9.7.ebuild60
3 files changed, 74 insertions, 0 deletions
diff --git a/dev-ruby/mod-ruby/ChangeLog b/dev-ruby/mod-ruby/ChangeLog
new file mode 100644
index 000000000000..cd56afe3e37f
--- /dev/null
+++ b/dev-ruby/mod-ruby/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for dev-ruby/mod-ruby
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mod-ruby/ChangeLog,v 1.1 2002/03/10 23:01:11 karltk Exp $
+
+*mod-ruby-0.9.7 ( 10 Mar 2002 )
+
+ 10 Mar 2002; Karl Trygve Kalleberg <karltk@gentoo.org> all :
+
+ mod_ruby embeds the Ruby interpreter into the Apache web server, allowing
+ Ruby CGI scripts to be executed natively. These scripts will start up much
+ faster than without mod_ruby.
+
+
diff --git a/dev-ruby/mod-ruby/files/digest-mod-ruby-0.9.7 b/dev-ruby/mod-ruby/files/digest-mod-ruby-0.9.7
new file mode 100644
index 000000000000..4b64c8c192d5
--- /dev/null
+++ b/dev-ruby/mod-ruby/files/digest-mod-ruby-0.9.7
@@ -0,0 +1 @@
+MD5 542ddd4bee5d5414cb7bb7beb36591a9 mod_ruby-0.9.7.tar.gz 41442
diff --git a/dev-ruby/mod-ruby/mod-ruby-0.9.7.ebuild b/dev-ruby/mod-ruby/mod-ruby-0.9.7.ebuild
new file mode 100644
index 000000000000..84799ab1c5be
--- /dev/null
+++ b/dev-ruby/mod-ruby/mod-ruby-0.9.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tools Team <tools@gentoo.org>
+# Author: Tuurlijk! <ebuilder@tuurlijk.eu.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mod-ruby/mod-ruby-0.9.7.ebuild,v 1.1 2002/03/10 23:01:11 karltk Exp $
+
+S=${WORKDIR}/mod_ruby-${PV}
+DESCRIPTION="A Ruby Module for Apache"
+SRC_URI="http://www.modruby.net/archive/mod_ruby-${PV}.tar.gz"
+HOMEPAGE="http://www.modruby.net"
+
+DEPEND="virtual/glibc
+ >=net-www/apache-1.3
+ >=dev-lang/ruby-1.6.1"
+
+src_compile() {
+ ruby ./configure.rb --with-apxs=/usr/sbin/apxs || die
+ make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc README.en README.ja ChangeLog COPYING
+}
+
+pkg_postinst() {
+ einfo "Run ebuild ruby-${PV}.ebuild config to update httpd.conf"
+}
+
+pkg_config() {
+ if [ -f "${ROOT}/etc/httpd/httpd.conf" ] ; then
+ einfo "Activating ruby interpretation for /ruby location"
+ cp ${ROOT}/etc/httpd/httpd.conf ${ROOT}/etc/httpd/httpd.conf.orig
+ echo "
+<IfDefine RUBY>
+LoadModule ruby_module /usr/lib/apache/mod_ruby.so
+</IfDefine>
+
+<IfDefine RUBY>
+AddModule mod_ruby.c
+</IfDefine>
+
+<IfModule mod_ruby.c>
+RubyRequire apache/ruby-run
+
+# Excucute files under /ruby as Ruby scripts
+<Location /ruby>
+ SetHandler ruby-object
+ RubyHandler Apache::RubyRun.instance
+</Location>
+
+# Execute *.rbx files as Ruby scripts
+<Files *.rbx>
+ SetHandler ruby-object
+ RubyHandler Apache::RubyRun.instance
+</Files>
+</IfModule>" >> ${ROOT}/etc/httpd/httpd.conf
+ einfo "Add -DRUBY to HTTPD_OPTS in ${ROOT}/etc/conf.d/httpd to activate mod_ruby"
+ fi
+}