summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-08-08 15:53:25 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-08-08 15:53:25 +0000
commit34cd9cea4d1bc55739edf5ecccdc9f67268db359 (patch)
tree9237851cd0d5141aaf7e2be55d1f79d8ea466810 /dev-ruby
parentVersion bump (diff)
downloadgentoo-2-34cd9cea4d1bc55739edf5ecccdc9f67268db359.tar.gz
gentoo-2-34cd9cea4d1bc55739edf5ecccdc9f67268db359.tar.bz2
gentoo-2-34cd9cea4d1bc55739edf5ecccdc9f67268db359.zip
Version bump
(Portage version: 2.1.13.6/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/tins/ChangeLog7
-rw-r--r--dev-ruby/tins/tins-0.8.3.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-ruby/tins/ChangeLog b/dev-ruby/tins/ChangeLog
index f38ae8bbdf6c..c9de76cea4f4 100644
--- a/dev-ruby/tins/ChangeLog
+++ b/dev-ruby/tins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/tins
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tins/ChangeLog,v 1.19 2013/05/13 04:57:55 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tins/ChangeLog,v 1.20 2013/08/08 15:53:25 mrueg Exp $
+
+*tins-0.8.3 (08 Aug 2013)
+
+ 08 Aug 2013; Manuel Rüger <mrueg@gentoo.org> +tins-0.8.3.ebuild:
+ Version bump
*tins-0.7.4 (13 May 2013)
diff --git a/dev-ruby/tins/tins-0.8.3.ebuild b/dev-ruby/tins/tins-0.8.3.ebuild
new file mode 100644
index 000000000000..a802a559ab17
--- /dev/null
+++ b/dev-ruby/tins/tins-0.8.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tins/tins-0.8.3.ebuild,v 1.1 2013/08/08 15:53:25 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="All the stuff that isn't good enough for a real library."
+HOMEPAGE="http://github.com/flori/tins"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 ) "
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib tests/*_test.rb
+}