summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-07-24 06:30:13 +0000
committerHans de Graaff <graaff@gentoo.org>2014-07-24 06:30:13 +0000
commit541c5c7879aedc4cd3e03156f7e7557772cb12e4 (patch)
tree3b2deb8fc427cbd69541e175e2778f94305294ce /dev-ruby
parentBump (diff)
downloadgentoo-2-541c5c7879aedc4cd3e03156f7e7557772cb12e4.tar.gz
gentoo-2-541c5c7879aedc4cd3e03156f7e7557772cb12e4.tar.bz2
gentoo-2-541c5c7879aedc4cd3e03156f7e7557772cb12e4.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/fast_gettext/ChangeLog7
-rw-r--r--dev-ruby/fast_gettext/fast_gettext-0.9.0.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/dev-ruby/fast_gettext/ChangeLog b/dev-ruby/fast_gettext/ChangeLog
index 825c1df53a6b..940f319065c4 100644
--- a/dev-ruby/fast_gettext/ChangeLog
+++ b/dev-ruby/fast_gettext/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/fast_gettext
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/ChangeLog,v 1.27 2014/06/26 09:00:00 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/ChangeLog,v 1.28 2014/07/24 06:30:13 graaff Exp $
+
+*fast_gettext-0.9.0 (24 Jul 2014)
+
+ 24 Jul 2014; Hans de Graaff <graaff@gentoo.org> +fast_gettext-0.9.0.ebuild:
+ Version bump.
26 Jun 2014; Hans de Graaff <graaff@gentoo.org> fast_gettext-0.8.1.ebuild:
Add ruby20, ruby21.
diff --git a/dev-ruby/fast_gettext/fast_gettext-0.9.0.ebuild b/dev-ruby/fast_gettext/fast_gettext-0.9.0.ebuild
new file mode 100644
index 000000000000..a732f4188d06
--- /dev/null
+++ b/dev-ruby/fast_gettext/fast_gettext-0.9.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/fast_gettext-0.9.0.ebuild,v 1.1 2014/07/24 06:30:13 graaff Exp $
+
+EAPI=5
+
+# jruby support requires sqlite3 support for jruby.
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG Readme.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="GetText but 3.5 x faster, 560 x less memory, simple, clean namespace (7 vs 34) and threadsave!"
+HOMEPAGE="https://github.com/grosser/fast_gettext"
+SRC_URI="https://github.com/grosser/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/activerecord dev-ruby/protected_attributes dev-ruby/bundler )"
+
+all_ruby_prepare() {
+ rm Gemfile.lock || die
+
+ # Remove jeweler and bump from Gemfile since they are not needed for tests.
+ sed -i -e '/jeweler/d' -e '/bump/d' -e '/appraisal/d' Gemfile || die
+
+ # Avoid unneeded dependency on git and development dependencies.
+ sed -e '/git ls-files/ s:^:#:' \
+ -e '/\(wwtd\|bump\)/ s:^:#:' \
+ -i fast_gettext.gemspec || die
+
+ # Don't run a test that requires safe mode which we can't provide
+ # due to insecure directory settings for the portage dir. This spec
+ # also calls out to ruby which won't work with different ruby
+ # implementations.
+ sed -i -e '/can work in SAFE mode/,/^ end/ s:^:#:' spec/fast_gettext/translation_repository/mo_spec.rb || die
+
+ # Avoid not failing pending specs related to ree18.
+ sed -i -e '/with i18n loaded/,/^ end/ s:^:#:' spec/fast_gettext/vendor/string_spec.rb || die
+
+ # Avoid RSpec 3 specific syntax
+ sed -e '/failure_message/ s:^:#:' -i spec/support/be_accessible_matcher.rb || die
+
+}
+
+each_ruby_prepare() {
+ # Make sure the right ruby interpreter is used
+ sed -i -e "s:bundle exec ruby:bundle exec ${RUBY}:" spec/fast_gettext/vendor/*spec.rb || die
+}