summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-03-18 07:14:58 +0000
committerHans de Graaff <graaff@gentoo.org>2010-03-18 07:14:58 +0000
commit85af9e64a24b06711185f5ab1ca49ea160c9e953 (patch)
tree8b4421959b6e1ba00330f04d1a18ed2629dc0d71 /dev-ruby
parentAdd a distfile with libsplashscreen.so built against libpng-1.4. The file is ... (diff)
downloadgentoo-2-85af9e64a24b06711185f5ab1ca49ea160c9e953.tar.gz
gentoo-2-85af9e64a24b06711185f5ab1ca49ea160c9e953.tar.bz2
gentoo-2-85af9e64a24b06711185f5ab1ca49ea160c9e953.zip
Version bump.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/log4r/ChangeLog7
-rw-r--r--dev-ruby/log4r/log4r-1.1.7.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ruby/log4r/ChangeLog b/dev-ruby/log4r/ChangeLog
index 7b2f4ac42e47..3a0f8a9e46b5 100644
--- a/dev-ruby/log4r/ChangeLog
+++ b/dev-ruby/log4r/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/log4r
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/log4r/ChangeLog,v 1.16 2010/02/15 16:57:29 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/log4r/ChangeLog,v 1.17 2010/03/18 07:14:58 graaff Exp $
+
+*log4r-1.1.7 (18 Mar 2010)
+
+ 18 Mar 2010; Hans de Graaff <graaff@gentoo.org> +log4r-1.1.7.ebuild:
+ Version bump.
15 Feb 2010; Hans de Graaff <graaff@gentoo.org> -log4r-1.1.4.ebuild,
-log4r-1.1.5.ebuild:
diff --git a/dev-ruby/log4r/log4r-1.1.7.ebuild b/dev-ruby/log4r/log4r-1.1.7.ebuild
new file mode 100644
index 000000000000..2fa0d438afd4
--- /dev/null
+++ b/dev-ruby/log4r/log4r-1.1.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/log4r/log4r-1.1.7.ebuild,v 1.1 2010/03/18 07:14:58 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+# There are no working tests atm, to be checked on next version bump.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README TODO"
+
+RUBY_FAKEGEM_EXTRAINSTALL="src"
+RUBY_FAKEGEM_REQUIRE_PATHS="src"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Log4r is a comprehensive and flexible logging library written in
+Ruby for use in Ruby programs."
+HOMEPAGE="http://log4r.sourceforge.net/"
+IUSE=""
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/* || die
+}