summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-12-24 10:20:04 +0000
committerHans de Graaff <graaff@gentoo.org>2010-12-24 10:20:04 +0000
commita554ef7e103cc82ec47e1e8f9f40f4ee3dcf2ff9 (patch)
tree4850f699d6b8ed09d97d0c32dfa92ef3b6c3d870 /dev-ruby
parentMarked ~ppc-macos (diff)
downloadgentoo-2-a554ef7e103cc82ec47e1e8f9f40f4ee3dcf2ff9.tar.gz
gentoo-2-a554ef7e103cc82ec47e1e8f9f40f4ee3dcf2ff9.tar.bz2
gentoo-2-a554ef7e103cc82ec47e1e8f9f40f4ee3dcf2ff9.zip
Version bump. Fixes bug 349546, thanks to matsuu for providing patches.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/i18n/ChangeLog7
-rw-r--r--dev-ruby/i18n/i18n-0.4.2.ebuild79
2 files changed, 85 insertions, 1 deletions
diff --git a/dev-ruby/i18n/ChangeLog b/dev-ruby/i18n/ChangeLog
index 742b783dfc84..963b035286a3 100644
--- a/dev-ruby/i18n/ChangeLog
+++ b/dev-ruby/i18n/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/i18n
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.24 2010/12/04 16:41:36 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.25 2010/12/24 10:20:04 graaff Exp $
+
+*i18n-0.4.2 (24 Dec 2010)
+
+ 24 Dec 2010; Hans de Graaff <graaff@gentoo.org> +i18n-0.4.2.ebuild:
+ Version bump. Fixes bug 349546, thanks to matsuu for providing patches.
04 Dec 2010; Fabian Groffen <grobian@gentoo.org> i18n-0.5.0.ebuild:
Added Prefix keywords
diff --git a/dev-ruby/i18n/i18n-0.4.2.ebuild b/dev-ruby/i18n/i18n-0.4.2.ebuild
new file mode 100644
index 000000000000..17a41ee4dd5e
--- /dev/null
+++ b/dev-ruby/i18n/i18n-0.4.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/i18n-0.4.2.ebuild,v 1.1 2010/12/24 10:20:04 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 jruby ree18"
+
+# doc regeneration seem to need Jeweler, which is not currently
+# available
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.textile CHANGELOG.textile"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Add Internationalization support to your Ruby application."
+HOMEPAGE="http://rails-i18n.org/"
+
+SRC_URI="http://github.com/svenfuchs/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
+S="${WORKDIR}/svenfuchs-${PN}-*"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~hppa ~ia64 ~sparc ~x86 ~ppc-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+# The testsuite uses the activerecord gem to run some tests; they
+# require sqlite3-ruby, and that is not available on JRuby.
+USE_RUBY="${USE_RUBY/jruby/}" \
+ ruby_add_bdepend "
+ test? (
+ dev-ruby/activerecord
+ dev-ruby/sqlite3-ruby
+ dev-ruby/ruby2ruby
+ )"
+
+# mocha is optionally used by the testsuite, try to increase coverage
+# of testing by depending on it; when mocha is used, though,
+# test-unit:2 cannot be merged at the same time (mocha problem?)
+#
+# One further test dependency would be ruby-cldr
+# (http://rubygems.org/gems/ruby-cldr) but we don't have it in tree
+# yet.
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha
+ !!dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ sed -i '/bundler/d' test/test_setup/bundle.rb || die "Unable to remove Bundler support"
+}
+
+src_compile() {
+ # permissions need to be stricter for Ruby-Inline to work properly.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+ ruby-ng_src_compile
+}
+
+src_test() {
+ # permissions need to be stricter for Ruby-Inline to work properly.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+ ruby-ng_src_test
+}
+
+each_ruby_test() {
+ # Make sure the optional activerecord tests are not run for jruby
+ # because we don't ship a compatible sqlite3
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ each_fakegem_test
+ esac
+}