summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-03-30 13:17:10 +0000
committerHans de Graaff <graaff@gentoo.org>2013-03-30 13:17:10 +0000
commita932b38d4ef509e5e63be6678fb34b297b3e903f (patch)
tree4cdd1c29de00acaee747a1484084b44c1371a9e6 /dev-ruby
parentVersion bump for security bug 462452. (diff)
downloadgentoo-2-a932b38d4ef509e5e63be6678fb34b297b3e903f.tar.gz
gentoo-2-a932b38d4ef509e5e63be6678fb34b297b3e903f.tar.bz2
gentoo-2-a932b38d4ef509e5e63be6678fb34b297b3e903f.zip
Version bump for security bug 462452.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionpack/ChangeLog7
-rw-r--r--dev-ruby/actionpack/actionpack-3.1.12.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index 0fe72edafd6b..0fdc929551a7 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.248 2013/03/30 09:32:29 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.249 2013/03/30 13:17:10 graaff Exp $
+
+*actionpack-3.1.12 (30 Mar 2013)
+
+ 30 Mar 2013; Hans de Graaff <graaff@gentoo.org> +actionpack-3.1.12.ebuild:
+ Version bump for security bug 462452.
*actionpack-2.3.18 (30 Mar 2013)
diff --git a/dev-ruby/actionpack/actionpack-3.1.12.ebuild b/dev-ruby/actionpack/actionpack-3.1.12.ebuild
new file mode 100644
index 000000000000..f8a269a670e6
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-3.1.12.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-3.1.12.ebuild,v 1.1 2013/03/30 13:17:10 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19"
+
+# The default test task tries to test activerecord with SQLite as well.
+RUBY_FAKEGEM_TASK_TEST="test_action_pack"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.1"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/actionpack"
+
+ruby_add_rdepend "
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/rack-cache-1.2
+ >=dev-ruby/builder-3.0.0:3
+ >=dev-ruby/erubis-2.7.0
+ >=dev-ruby/i18n-0.6:0.6
+ >=dev-ruby/rack-1.3.6:1.3
+ >=dev-ruby/rack-mount-0.8.2:0.8
+ >=dev-ruby/rack-test-0.6.1:0.6
+ >=dev-ruby/sprockets-2.0.4:2.0"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha
+ dev-ruby/bundler
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ >=dev-ruby/tzinfo-0.3.29
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e '/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|"mysql"\|ruby-prof\|benchmark-ips\)/d' ../Gemfile || die
+
+ sed -i -e '/\(rack-ssl\|thor\)/d' ../railties/railties.gemspec || die
+ sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
+ sed -i -e "s/, '< 1.3'//" ../activesupport/activesupport.gemspec || die
+
+ # Loosen mocha version restriction
+ sed -i -e 's/0.10.5/>= 0.10.5/' ../Gemfile || die
+
+ # Avoid fragile tests depending on hash ordering
+ sed -i -e '/cookie_3=chocolate/ s:^:#:' test/controller/integration_test.rb || die
+ sed -i -e '/test_to_s/,/end/ s:^:#:' test/template/html-scanner/tag_node_test.rb || die
+ sed -i -e '/"name":"david"/ s:^:#:' test/controller/mime_responds_test.rb || die
+ sed -i -e '/test_option_html_attributes_with_multiple_element_hash/, / end/ s:^:#:' test/template/form_options_helper_test.rb || die
+ sed -i -e '/test_option_html_attributes_with_multiple_hashes/, / end/ s:^:#:' test/template/form_options_helper_test.rb || die
+}