summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-02-21 20:10:46 +0000
committerHans de Graaff <graaff@gentoo.org>2011-02-21 20:10:46 +0000
commitf4eaa48049ac197e5313e337a7e42e1c198643d8 (patch)
treec35de08615fbd2839d31b90d83ff9ac40414c249 /dev-ruby
parentVersion bump for Rails 2.3.11. (diff)
downloadgentoo-2-f4eaa48049ac197e5313e337a7e42e1c198643d8.tar.gz
gentoo-2-f4eaa48049ac197e5313e337a7e42e1c198643d8.tar.bz2
gentoo-2-f4eaa48049ac197e5313e337a7e42e1c198643d8.zip
Version bump for Rails 2.3.11.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionmailer/ChangeLog8
-rw-r--r--dev-ruby/actionmailer/actionmailer-2.3.11.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index 2fc9784d0cba..2341e5874246 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.153 2011/02/21 19:42:10 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.154 2011/02/21 20:10:46 graaff Exp $
+
+*actionmailer-2.3.11 (21 Feb 2011)
+
+ 21 Feb 2011; Hans de Graaff <graaff@gentoo.org>
+ +actionmailer-2.3.11.ebuild:
+ Version bump for Rails 2.3.11.
21 Feb 2011; Hans de Graaff <graaff@gentoo.org>
actionmailer-2.3.10.ebuild, +files/actionmailer-2.3.10-rails3.patch:
diff --git a/dev-ruby/actionmailer/actionmailer-2.3.11.ebuild b/dev-ruby/actionmailer/actionmailer-2.3.11.ebuild
new file mode 100644
index 000000000000..8d71c436b449
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-2.3.11.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-2.3.11.ebuild,v 1.1 2011/02/21 20:10:46 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_PATCHES=( "${PN}-2.3.10-rails3.patch" )
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/text-format-0.6.3
+ >=dev-ruby/tmail-1.2.3"
+ruby_add_bdepend "test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+)"
+
+all_ruby_prepare() {
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+}