summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomás Touceda <chiiph@gentoo.org>2010-04-07 14:21:52 +0000
committerTomás Touceda <chiiph@gentoo.org>2010-04-07 14:21:52 +0000
commit84549343076d01cdf3a4428fc3db4010dced8ff5 (patch)
tree4f649cf6e032665bd0eb93e6239d01fabec3c3aa /dev-scheme
parentInitial commit wrt #309759 by Marc-Antoine Perennou. (diff)
downloadgentoo-2-84549343076d01cdf3a4428fc3db4010dced8ff5.tar.gz
gentoo-2-84549343076d01cdf3a4428fc3db4010dced8ff5.tar.bz2
gentoo-2-84549343076d01cdf3a4428fc3db4010dced8ff5.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/bigloo/ChangeLog8
-rw-r--r--dev-scheme/bigloo/bigloo-3.3a_p5.ebuild112
-rw-r--r--dev-scheme/bigloo/files/bigloo-3.3a_p5-no_strip.patch32
3 files changed, 151 insertions, 1 deletions
diff --git a/dev-scheme/bigloo/ChangeLog b/dev-scheme/bigloo/ChangeLog
index ef9d08d83674..7b9090ce4aca 100644
--- a/dev-scheme/bigloo/ChangeLog
+++ b/dev-scheme/bigloo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-scheme/bigloo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/ChangeLog,v 1.35 2010/01/31 19:46:55 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/ChangeLog,v 1.36 2010/04/07 14:21:52 chiiph Exp $
+
+*bigloo-3.3a_p5 (07 Apr 2010)
+
+ 07 Apr 2010; <chiiph@gentoo.org> +bigloo-3.3a_p5.ebuild,
+ +files/bigloo-3.3a_p5-no_strip.patch:
+ Version bump
31 Jan 2010; Torsten Veller <tove@gentoo.org> bigloo-3.2b_p2.ebuild:
Change vecho to echo
diff --git a/dev-scheme/bigloo/bigloo-3.3a_p5.ebuild b/dev-scheme/bigloo/bigloo-3.3a_p5.ebuild
new file mode 100644
index 000000000000..92af14f25181
--- /dev/null
+++ b/dev-scheme/bigloo/bigloo-3.3a_p5.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/bigloo-3.3a_p5.ebuild,v 1.1 2010/04/07 14:21:52 chiiph Exp $
+
+EAPI="2"
+
+inherit elisp-common multilib eutils flag-o-matic java-pkg-2
+
+MY_P=${PN}${PV/_p/-}
+MY_P=${MY_P/_alpha/-alpha}
+MY_P=${MY_P/_beta/-beta}
+
+DESCRIPTION="Bigloo is a Scheme implementation."
+HOMEPAGE="http://www-sop.inria.fr/indes/fp/Bigloo/bigloo.html"
+SRC_URI="ftp://ftp-sop.inria.fr/indes/fp/Bigloo/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+# bug 254916 for >=dev-libs/boehm-gc-7.1
+DEPEND=">=dev-libs/boehm-gc-7.1[threads?]
+ emacs? ( virtual/emacs )
+ java? ( virtual/jdk app-arch/zip )
+ ssl? ( dev-libs/openssl )
+ gstreamer? ( media-libs/gstreamer
+ media-libs/gst-plugins-base )"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+SITEFILE="50bigloo-gentoo.el"
+
+IUSE="emacs java ssl threads gstreamer"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-no_strip.patch"
+
+ # Removing bundled boehm-gc
+ rm -rf gc || die
+}
+
+src_configure() {
+ filter-flags -fomit-frame-pointer
+
+ if ! use threads && use gstreamer; then
+ eerror "You must enable threads in order to build with gstreamer support"
+ die
+ fi
+
+ # Bigloo doesn't use autoconf and consequently a lot of options used by econf give errors
+ # Manuel Serrano says: "Please, dont talk to me about autoconf. I simply dont want to hear about it..."
+ ./configure \
+ $(use java && echo "--jvm=yes --java=$(java-config --java) --javac=$(java-config --javac)") \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --libdir=/usr/$(get_libdir) \
+ --docdir=/usr/share/doc/${PF} \
+ --lispdir="${SITELISP}/${PN}" \
+ --benchmark=yes \
+ --sharedbde=no \
+ --sharedcompiler=no \
+ --customgc=no \
+ --coflags="" \
+ --strip=no \
+ --bee=$(if use emacs; then echo full; else echo partial; fi) \
+ $(use_enable threads fthread) \
+ $(use_enable threads pthread) \
+ $(use_enable gstreamer) \
+ $(use_enable ssl) \
+ || die "configure failed"
+
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+
+ if use emacs; then
+ einfo "Compiling bee..."
+ emake -j1 compile-bee || die "compiling bee failed"
+ fi
+}
+
+# default thinks that target doesn't exist
+src_test() {
+ echo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ emake test || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ if use emacs; then
+ emake DESTDIR="${D}" install-bee || die "install-bee failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ if use emacs; then
+ elog "In order to use the bee-mode, add"
+ elog " (require 'bmacs)"
+ elog "to your ~/.emacs file"
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-scheme/bigloo/files/bigloo-3.3a_p5-no_strip.patch b/dev-scheme/bigloo/files/bigloo-3.3a_p5-no_strip.patch
new file mode 100644
index 000000000000..7a3b1190551f
--- /dev/null
+++ b/dev-scheme/bigloo/files/bigloo-3.3a_p5-no_strip.patch
@@ -0,0 +1,32 @@
+diff -Naur bigloo3.3a.orig/configure bigloo3.3a/configure
+--- bigloo3.3a.orig/configure 2009-12-01 11:13:15.000000000 -0300
++++ bigloo3.3a/configure 2009-12-11 02:08:57.000000000 -0300
+@@ -62,7 +62,7 @@
+ featureflags=
+ coflags=-O3
+
+-cstrip="-s"
++cstrip=""
+ cpicflags="demanded" # Possible values for cpicflags are:
+ # - "no" not to use position independent code (recommended)
+ # - "demanded" auto configuration but with a preference to "no"
+@@ -78,7 +78,7 @@
+ ld=
+ ldlibs=-lc
+ ldcomplibs=-lc
+-strip= # left blank for autoconfiguration
++strip="" # left blank for autoconfiguration
+ longlong= # The C type to represent long long integers
+ havelonglong=
+ stringsplit="0"
+@@ -684,6 +684,10 @@
+ extralibs="";
+ cstrip="no";;
+
++ --strip=no)
++ cstrip="no";
++ strip="no";;
++
+ --pnet)
+ dotnetclrstyle=pnet;
+ dotnetcsccstyle=pnet;