summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-03-24 21:30:28 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-03-24 21:30:28 +0000
commit388bd7aece8f484b5f5d0eaa141aa9738b2d53fa (patch)
tree9251458225dbca23b640db87b6dccd78a409899f /dev-tcltk/mysqltcl
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-388bd7aece8f484b5f5d0eaa141aa9738b2d53fa.tar.gz
gentoo-2-388bd7aece8f484b5f5d0eaa141aa9738b2d53fa.tar.bz2
gentoo-2-388bd7aece8f484b5f5d0eaa141aa9738b2d53fa.zip
Bug #264690: fix compile on non-symlink multilib systems.
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk/mysqltcl')
-rw-r--r--dev-tcltk/mysqltcl/ChangeLog7
-rw-r--r--dev-tcltk/mysqltcl/mysqltcl-3.05.ebuild11
2 files changed, 14 insertions, 4 deletions
diff --git a/dev-tcltk/mysqltcl/ChangeLog b/dev-tcltk/mysqltcl/ChangeLog
index d898e95320c4..c9f7fffc5b76 100644
--- a/dev-tcltk/mysqltcl/ChangeLog
+++ b/dev-tcltk/mysqltcl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-tcltk/mysqltcl
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/mysqltcl/ChangeLog,v 1.13 2009/08/08 01:08:07 mescalinum Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/mysqltcl/ChangeLog,v 1.14 2010/03/24 21:30:28 robbat2 Exp $
+
+ 24 Mar 2010; Robin H. Johnson <robbat2@gentoo.org> mysqltcl-3.05.ebuild:
+ Bug #264690: fix compile on non-symlink multilib systems.
*mysqltcl-3.05 (08 Aug 2009)
diff --git a/dev-tcltk/mysqltcl/mysqltcl-3.05.ebuild b/dev-tcltk/mysqltcl/mysqltcl-3.05.ebuild
index 3dac1c88eb94..f46015347da3 100644
--- a/dev-tcltk/mysqltcl/mysqltcl-3.05.ebuild
+++ b/dev-tcltk/mysqltcl/mysqltcl-3.05.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/mysqltcl/mysqltcl-3.05.ebuild,v 1.1 2009/08/08 01:08:07 mescalinum Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/mysqltcl/mysqltcl-3.05.ebuild,v 1.2 2010/03/24 21:30:28 robbat2 Exp $
+
+inherit multilib
DESCRIPTION="TCL MySQL Interface"
HOMEPAGE="http://www.xdobry.de/mysqltcl/"
@@ -21,3 +23,8 @@ src_install() {
dohtml doc/mysqltcl.html
prepalldocs
}
+
+src_compile() {
+ econf --with-mysql-lib=/usr/$(get_libdir)/mysql || die
+ emake || die
+}