summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-26 13:51:18 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-26 13:51:18 +0000
commit8531d3c9e432b572810ab81bef4cee9c074d02b4 (patch)
tree0db9581d0fc26c479cbe61c494390199ae0fb582 /dev-tcltk/tclpython
parenttouchups (Manifest recommit) (diff)
downloadgentoo-2-8531d3c9e432b572810ab81bef4cee9c074d02b4.tar.gz
gentoo-2-8531d3c9e432b572810ab81bef4cee9c074d02b4.tar.bz2
gentoo-2-8531d3c9e432b572810ab81bef4cee9c074d02b4.zip
use $(tc-getCC)
Diffstat (limited to 'dev-tcltk/tclpython')
-rw-r--r--dev-tcltk/tclpython/tclpython-3.1.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-tcltk/tclpython/tclpython-3.1.ebuild b/dev-tcltk/tclpython/tclpython-3.1.ebuild
index bd19606c43c9..927fdee9331e 100644
--- a/dev-tcltk/tclpython/tclpython-3.1.ebuild
+++ b/dev-tcltk/tclpython/tclpython-3.1.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclpython/tclpython-3.1.ebuild,v 1.3 2004/10/17 10:14:24 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclpython/tclpython-3.1.ebuild,v 1.4 2004/10/26 13:51:18 vapier Exp $
-inherit distutils
+inherit distutils toolchain-funcs
DESCRIPTION="a Python package for Tcl"
HOMEPAGE="http://jfontain.free.fr/tclperl.htm"
SRC_URI="http://jfontain.free.fr/${P}.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64 ~ppc"
SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
DEPEND=">=dev-lang/tcl-8.0
@@ -18,13 +18,13 @@ DEPEND=">=dev-lang/tcl-8.0
src_compile() {
distutils_python_version
- ${CC} -shared -o tclpython.so.${PV} -s -fPIC ${CFLAGS} -Wall -I/usr/include/python${PYVER} tclpython.c `python-config` -lpthread -lutil || die
+ $(tc-getCC) -shared -o tclpython.so.${PV} -s -fPIC ${CFLAGS} -Wall -I/usr/include/python${PYVER} tclpython.c `python-config` -lpthread -lutil || die
}
src_install() {
- insinto /usr/lib/tclpython
- doins tclpython.so.${PV}
- doins pkgIndex.tcl
+ exeinto /usr/lib/tclpython
+ doexe tclpython.so.${PV} || die "lib"
+ doexe pkgIndex.tcl || die "tcl"
dodoc CHANGES INSTALL README
dohtml tclpython.htm