summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2005-03-27 02:09:48 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2005-03-27 02:09:48 +0000
commit84c1fd98f91469c7d361ede6bc05b5b55f16626a (patch)
tree4af550452da4c49654f32c8c4e8a6185e49babf6 /dev-tcltk/tdom
parentbug 86814 (diff)
downloadgentoo-2-84c1fd98f91469c7d361ede6bc05b5b55f16626a.tar.gz
gentoo-2-84c1fd98f91469c7d361ede6bc05b5b55f16626a.tar.bz2
gentoo-2-84c1fd98f91469c7d361ede6bc05b5b55f16626a.zip
Initial ebuild. Submitted by Travis Cross, Bug #31812.
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-tcltk/tdom')
-rw-r--r--dev-tcltk/tdom/ChangeLog9
-rw-r--r--dev-tcltk/tdom/Manifest2
-rw-r--r--dev-tcltk/tdom/files/digest-tdom-0.8.01
-rw-r--r--dev-tcltk/tdom/metadata.xml5
-rw-r--r--dev-tcltk/tdom/tdom-0.8.0.ebuild52
5 files changed, 69 insertions, 0 deletions
diff --git a/dev-tcltk/tdom/ChangeLog b/dev-tcltk/tdom/ChangeLog
new file mode 100644
index 000000000000..d8f791c65312
--- /dev/null
+++ b/dev-tcltk/tdom/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-tcltk/tdom
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tdom/ChangeLog,v 1.1 2005/03/27 02:09:48 matsuu Exp $
+
+*tdom-0.8.0 (27 Mar 2005)
+
+ 27 Mar 2005; MATSUU Takuto <matsuu@gentoo.org> +tdom-0.8.0.ebuild:
+ Initial ebuild. Submitted by Travis Cross, bug #31812.
+
diff --git a/dev-tcltk/tdom/Manifest b/dev-tcltk/tdom/Manifest
new file mode 100644
index 000000000000..46b8ae9520a2
--- /dev/null
+++ b/dev-tcltk/tdom/Manifest
@@ -0,0 +1,2 @@
+MD5 0be031f737684adfc2a32f48c377952e tdom-0.8.0.ebuild 1107
+MD5 dab542ee516f7847f573d6d8b0d4d5da files/digest-tdom-0.8.0 62
diff --git a/dev-tcltk/tdom/files/digest-tdom-0.8.0 b/dev-tcltk/tdom/files/digest-tdom-0.8.0
new file mode 100644
index 000000000000..d969191d0da6
--- /dev/null
+++ b/dev-tcltk/tdom/files/digest-tdom-0.8.0
@@ -0,0 +1 @@
+MD5 90626edf33b7a77229a23b9132f74977 tDOM-0.8.0.tar.gz 886455
diff --git a/dev-tcltk/tdom/metadata.xml b/dev-tcltk/tdom/metadata.xml
new file mode 100644
index 000000000000..d9408d8ab078
--- /dev/null
+++ b/dev-tcltk/tdom/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tcltk</herd>
+</pkgmetadata>
diff --git a/dev-tcltk/tdom/tdom-0.8.0.ebuild b/dev-tcltk/tdom/tdom-0.8.0.ebuild
new file mode 100644
index 000000000000..82c6f1d2736a
--- /dev/null
+++ b/dev-tcltk/tdom/tdom-0.8.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tdom/tdom-0.8.0.ebuild,v 1.1 2005/03/27 02:09:48 matsuu Exp $
+
+MY_P="tDOM-${PV}"
+DESCRIPTION="XML manipulation library for TCL"
+HOMEPAGE="http://www.tdom.org/"
+SRC_URI="http://www.tdom.org/files/${MY_P}.tar.gz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="threads"
+
+DEPEND=">=dev-lang/tcl-8.4.3"
+
+S="${WORKDIR}/${MY_P}"
+
+
+src_compile() {
+ local myconf=""
+
+ myconf="${myconf} --enable-shared `use_enable threads`"
+
+ cd ${S}/unix
+ ECONF_SOURCE=".." econf ${myconf} || die "failed to configure"
+ emake || die "failed to compile tdom"
+
+ # compile tdomhtml
+ cd ${S}/extensions/tdomhtml
+ econf || die "fail to configure tdomhtml"
+ emake || die "fail to compile tdomhtml"
+
+ # compile tnc
+ cd ${S}/extensions/tnc
+ econf ${myconf} || die "failed to configure tnc"
+ emake || die "failed to compile tnc"
+}
+
+src_install() {
+ cd ${S}/unix
+ make DESTDIR=${D} install || die
+
+ cd ${S}/extensions/tdomhtml
+ make DESTDIR=${D} install || die
+
+ cd ${S}/extensions/tnc
+ make DESTDIR=${D} install || die
+
+ cd ${S}
+ dodoc CHANGES ChangeLog README*
+}