summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-08-14 00:45:12 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-08-14 00:45:12 +0000
commit19bbf54a812464ec7454da87f9ea9fc6e3be2d39 (patch)
tree2ce42c39dd9a890e2d3563bdc2643c32772e6d1d /dev-tcltk
parentstable x86, bug 280839 (diff)
downloadgentoo-2-19bbf54a812464ec7454da87f9ea9fc6e3be2d39.tar.gz
gentoo-2-19bbf54a812464ec7454da87f9ea9fc6e3be2d39.tar.bz2
gentoo-2-19bbf54a812464ec7454da87f9ea9fc6e3be2d39.zip
port to EAPI 2
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/thread/ChangeLog5
-rw-r--r--dev-tcltk/thread/thread-2.6.2.ebuild22
2 files changed, 10 insertions, 17 deletions
diff --git a/dev-tcltk/thread/ChangeLog b/dev-tcltk/thread/ChangeLog
index 4b3d796acd06..b229dc740954 100644
--- a/dev-tcltk/thread/ChangeLog
+++ b/dev-tcltk/thread/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-tcltk/thread
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/ChangeLog,v 1.15 2009/08/08 01:47:40 mescalinum Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/ChangeLog,v 1.16 2009/08/14 00:45:12 fauli Exp $
+
+ 14 Aug 2009; Christian Faulhammer <fauli@gentoo.org> thread-2.6.2.ebuild:
+ port to EAPI 2
08 Aug 2009; Federico Ferri <mescalinum@gentoo.org> thread-2.6.2.ebuild:
fix bug 247586
diff --git a/dev-tcltk/thread/thread-2.6.2.ebuild b/dev-tcltk/thread/thread-2.6.2.ebuild
index 1bfda3aa00de..3307965d594b 100644
--- a/dev-tcltk/thread/thread-2.6.2.ebuild
+++ b/dev-tcltk/thread/thread-2.6.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/thread-2.6.2.ebuild,v 1.14 2009/08/08 01:47:40 mescalinum Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/thread-2.6.2.ebuild,v 1.15 2009/08/14 00:45:12 fauli Exp $
+
+EAPI=2
inherit autotools eutils multilib
@@ -14,25 +16,14 @@ KEYWORDS="~alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86
IUSE="gdbm"
DEPEND="gdbm? ( sys-libs/gdbm )
- dev-lang/tcl"
+ dev-lang/tcl[threads]"
RDEPEND="${DEPEND}"
S=${WORKDIR}/${PN}${PV}
RESTRICT="test"
-pkg_setup() {
- if ! built_with_use dev-lang/tcl threads ; then
- eerror "dev-lang/tcl was not merged with threading enabled."
- eerror "please re-emerge dev-lang/tcl with USE=threads"
- die "threading not enabled in dev-lang/tcl"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# Search for libs in libdir not just exec_prefix/lib
sed -i -e 's:${exec_prefix}/lib:${libdir}:' \
aclocal.m4 || die "sed failed"
@@ -43,7 +34,7 @@ src_unpack() {
eautoconf
}
-src_compile() {
+src_configure() {
local use_gdbm=""
if use gdbm; then use_gdbm="--with-gdbm"; fi
econf \
@@ -51,7 +42,6 @@ src_compile() {
--with-tclinclude=/usr/include \
--with-tcl="/usr/$(get_libdir)" \
${use_gdbm} || die "econf failed"
- emake || die "emake failed"
}
src_install() {