summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-04-29 15:26:16 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-04-29 15:26:16 +0000
commit7776f90bbd78c27f75aa62936ccc4aa842eec2eb (patch)
tree93b5a954c04d4317c83501c8c79076fa3e2e8360 /dev-tex/latexmk
parentversion bump, bug #541384; properly remove all .la files, bug #537476 (diff)
downloadgentoo-2-7776f90bbd78c27f75aa62936ccc4aa842eec2eb.tar.gz
gentoo-2-7776f90bbd78c27f75aa62936ccc4aa842eec2eb.tar.bz2
gentoo-2-7776f90bbd78c27f75aa62936ccc4aa842eec2eb.zip
version bump
Signed-off-by: Alexis Ballier <aballier@gentoo.org> (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-tex/latexmk')
-rw-r--r--dev-tex/latexmk/ChangeLog7
-rw-r--r--dev-tex/latexmk/latexmk-443a.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-tex/latexmk/ChangeLog b/dev-tex/latexmk/ChangeLog
index 8a8b78495f29..b8c5d1272cf1 100644
--- a/dev-tex/latexmk/ChangeLog
+++ b/dev-tex/latexmk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tex/latexmk
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/latexmk/ChangeLog,v 1.71 2015/01/05 23:30:29 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/latexmk/ChangeLog,v 1.72 2015/04/29 15:26:16 aballier Exp $
+
+*latexmk-443a (29 Apr 2015)
+
+ 29 Apr 2015; Alexis Ballier <aballier@gentoo.org> +latexmk-443a.ebuild:
+ version bump
*latexmk-441 (05 Jan 2015)
diff --git a/dev-tex/latexmk/latexmk-443a.ebuild b/dev-tex/latexmk/latexmk-443a.ebuild
new file mode 100644
index 000000000000..487627f64d8c
--- /dev/null
+++ b/dev-tex/latexmk/latexmk-443a.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/latexmk/latexmk-443a.ebuild,v 1.1 2015/04/29 15:26:16 aballier Exp $
+
+EAPI=5
+
+inherit bash-completion-r1
+
+DESCRIPTION="Perl script for automatically building LaTeX documents"
+HOMEPAGE="http://www.phys.psu.edu/~collins/software/latexmk/"
+SRC_URI="http://www.phys.psu.edu/~collins/software/latexmk/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="virtual/latex-base
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ newbin latexmk.pl latexmk
+ doman latexmk.1
+ dodoc CHANGES README latexmk.pdf latexmk.ps latexmk.txt
+ dodoc -r example_rcfiles extra-scripts
+ newbashcomp "${FILESDIR}"/completion.bash-2 ${PN}
+}