summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-07 03:35:15 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-07 03:35:15 +0000
commit9d54ef8c61839b12b04e3f719f44822578952d2b (patch)
tree42e96e1d4a6c36d7019ce455f02128719347fc90 /dev-tex
parentfix license/repoman (diff)
downloadgentoo-2-9d54ef8c61839b12b04e3f719f44822578952d2b.tar.gz
gentoo-2-9d54ef8c61839b12b04e3f719f44822578952d2b.tar.bz2
gentoo-2-9d54ef8c61839b12b04e3f719f44822578952d2b.zip
fix license/repoman
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/cpp2latex/cpp2latex-2.2.ebuild29
-rw-r--r--dev-tex/cweb_latex/cweb_latex-1.1.1.ebuild13
2 files changed, 24 insertions, 18 deletions
diff --git a/dev-tex/cpp2latex/cpp2latex-2.2.ebuild b/dev-tex/cpp2latex/cpp2latex-2.2.ebuild
index c1c0dc450a5f..a91be496cc41 100644
--- a/dev-tex/cpp2latex/cpp2latex-2.2.ebuild
+++ b/dev-tex/cpp2latex/cpp2latex-2.2.ebuild
@@ -1,30 +1,31 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/cpp2latex/cpp2latex-2.2.ebuild,v 1.1 2003/06/09 07:32:39 satai Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/cpp2latex/cpp2latex-2.2.ebuild,v 1.2 2003/08/07 03:32:58 vapier Exp $
+
+inherit eutils
-S=${WORKDIR}/${P}
DESCRIPTION="A program to convert C++ code to LaTeX source"
-SRC_URI="http://www.arnoldarts.de/${P}.tar.gz"
HOMEPAGE="http://www.arnoldarts.de/cpp2latex.html"
+SRC_URI="http://www.arnoldarts.de/${P}.tar.gz"
-DEPEND="virtual/glibc
- app-text/tetex"
-
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ppc"
+DEPEND="virtual/glibc
+ app-text/tetex"
+
src_unpack () {
unpack ${A}
cd ${S}
- patch -p 0 < ${FILESDIR}/main.cpp.patch
+ epatch ${FILESDIR}/main.cpp.patch
}
-src_compile () {
- econf
- emake
+src_compile() {
+ econf || die
+ emake || die
}
-src_install () {
- make install DESTDIR=${D} || die make install failed
+src_install() {
+ make install DESTDIR=${D} || die make install failed
}
diff --git a/dev-tex/cweb_latex/cweb_latex-1.1.1.ebuild b/dev-tex/cweb_latex/cweb_latex-1.1.1.ebuild
index 887ad91cce3a..06838ad975a7 100644
--- a/dev-tex/cweb_latex/cweb_latex-1.1.1.ebuild
+++ b/dev-tex/cweb_latex/cweb_latex-1.1.1.ebuild
@@ -1,17 +1,22 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/cweb_latex/cweb_latex-1.1.1.ebuild,v 1.2 2003/08/07 03:33:41 vapier Exp $
+
+PATCHES="${FILESDIR}/cweb.cls.patch"
inherit latex-package
-S="${WORKDIR}/cweb-sty-${PV}"
DESCRIPTION="LaTeX package for using LaTeX with CWEB"
SRC_URI="ftp://ftp.th-darmstadt.de//programming/literate-programming/c.c++/cweb-sty-${PV}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 mips"
-PATCHES="${FILESDIR}/cweb.cls.patch"
-# this package has a .tex file which needs to go with the cweb.sty
+S="${WORKDIR}/cweb-sty-${PV}"
+
src_install() {
- cd ${S}
latex-package_src_install
+ # this package has a .tex file which needs to go with the cweb.sty
insinto ${TEXMF}/tex/latex/${PN}
doins cwebbase.tex
}