summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-05-20 00:45:24 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-05-20 00:45:24 +0000
commitfc749b493be009fa98dbfbea8b26518ca8e1e1e0 (patch)
tree15081e34eda8ca7caf2e199dd23553fcb022e088 /dev-util/arch
parentNew package (diff)
downloadgentoo-2-fc749b493be009fa98dbfbea8b26518ca8e1e1e0.tar.gz
gentoo-2-fc749b493be009fa98dbfbea8b26518ca8e1e1e0.tar.bz2
gentoo-2-fc749b493be009fa98dbfbea8b26518ca8e1e1e0.zip
Updated package
Diffstat (limited to 'dev-util/arch')
-rw-r--r--dev-util/arch/ChangeLog10
-rw-r--r--dev-util/arch/arch-1.0_pre15.ebuild75
-rw-r--r--dev-util/arch/files/digest-arch-1.0_pre151
3 files changed, 84 insertions, 2 deletions
diff --git a/dev-util/arch/ChangeLog b/dev-util/arch/ChangeLog
index e675f398ab66..44fdd742d9e9 100644
--- a/dev-util/arch/ChangeLog
+++ b/dev-util/arch/ChangeLog
@@ -1,6 +1,12 @@
-# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# ChangeLog for dev-util/arch
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-util/arch/ChangeLog,v 1.3 2002/04/09 11:19:40 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/arch/ChangeLog,v 1.4 2002/05/20 00:45:24 rphillips Exp $
+
+*arch-1.0_pre15 (19 Apr 2002)
+
+ 19 Apr 2002; Ryan Phillips <rphillips@gentoo.org> arch-1.0_pre15.ebuild:
+
+ Bumped up version to arch-1.0_pre15.
*arch-1.0_pre14 (06 Apr 2002)
diff --git a/dev-util/arch/arch-1.0_pre15.ebuild b/dev-util/arch/arch-1.0_pre15.ebuild
new file mode 100644
index 000000000000..e78e58dcd94e
--- /dev/null
+++ b/dev-util/arch/arch-1.0_pre15.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2.
+# Maintainer: Chris Houser <chouser@gentoo.org>
+# Author: Defresne Sylvain (keiichi) <kamisama@free.fr>, Chris Houser <chouser@gentoo.org>
+
+
+MY_P="${P//_/}"
+S="${WORKDIR}/${MY_P}/src/=build"
+DESCRIPTION="revision control system ideal for widely distributed development"
+SRC_URI="ftp://regexps.com/pub/src/arch/${MY_P}.tar.gz"
+HOMEPAGE="http://www.regexps.com/#arch"
+SLOT="0"
+
+DEPEND="sys-apps/diffutils
+ sys-apps/fileutils
+ sys-apps/findutils
+ sys-apps/gawk
+ sys-apps/sh-utils
+ sys-apps/tar
+ sys-apps/textutils
+ sys-apps/util-linux
+ sys-apps/debianutils
+ sys-devel/make
+ sys-devel/patch"
+
+src_unpack() {
+ local t
+
+ unpack "${A}"
+ mkdir -p "${MY_P}/src/=build"
+
+ # patch arch to install its scripts in /usr/share/arch
+ # instead of /usr/libexec/arch (there is only shareables scripts).
+ t="${MY_P}/src/build-tools/Makefiles/rules.mk"
+
+ cp ${t} ${t}.orig
+ sed 's:/libexec:/share:g' ${t}.orig > ${t} || die "Patch failed for $t"
+}
+
+src_compile() {
+ # configure
+ ../configure --prefix="/usr" \
+ --with-posix-shell="/bin/bash" \
+ --with-sendmail="/usr/sbin/sendmail" || die "configure failed"
+
+ # parallel make may cause problems with this package
+ make || die "make failed"
+}
+
+src_install () {
+ local name
+
+ # install
+ make install prefix="${D}/usr" \
+ || die "make install failed"
+
+ # make symlinks relative instead of absolute
+ for name in ${D}/usr/share/arch/arch/*; do
+ name="`readlink ${name} | sed 's:^.*/usr/share/arch/::'`"
+ if [ "${name}" ]; then
+ ln -sf "../${name}" "${D}/usr/share/arch/arch/${name#*/}"
+ assert "Fixing symlink for ${name} failed"
+ fi
+ done
+
+ # get some docs
+ cd ${WORKDIR}/${MY_P}
+ dodoc =NEWS =README COPYING
+ dohtml docs/html/*
+}
+
+pkg_postinst() {
+ echo "Tom Lord's 'arch' command has been renamed upstream to 'larch'"
+ echo "to stop collision with 'arch' command."
+}
diff --git a/dev-util/arch/files/digest-arch-1.0_pre15 b/dev-util/arch/files/digest-arch-1.0_pre15
new file mode 100644
index 000000000000..9847b5cc0cda
--- /dev/null
+++ b/dev-util/arch/files/digest-arch-1.0_pre15
@@ -0,0 +1 @@
+MD5 e2534ecdd523f72d5837a9aa2dc7b1f9 arch-1.0pre15.tar.gz 2617059