summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2004-09-26 23:17:46 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2004-09-26 23:17:46 +0000
commitccf623a3cd58a89f2793091d95cca780ffe4df8e (patch)
treec9221a8d8803a06235b163fc7a47c7e02d661974 /dev-util/astyle
parentinitial commit (Manifest recommit) (diff)
downloadgentoo-2-ccf623a3cd58a89f2793091d95cca780ffe4df8e.tar.gz
gentoo-2-ccf623a3cd58a89f2793091d95cca780ffe4df8e.tar.bz2
gentoo-2-ccf623a3cd58a89f2793091d95cca780ffe4df8e.zip
Fixed gcc-3.4 compile issues
Diffstat (limited to 'dev-util/astyle')
-rw-r--r--dev-util/astyle/ChangeLog7
-rw-r--r--dev-util/astyle/astyle-1.15.3-r1.ebuild5
-rw-r--r--dev-util/astyle/astyle-1.15.3.ebuild5
-rw-r--r--dev-util/astyle/files/astyle-gcc34.patch10
4 files changed, 24 insertions, 3 deletions
diff --git a/dev-util/astyle/ChangeLog b/dev-util/astyle/ChangeLog
index 327bfb85998a..9aa9442f9950 100644
--- a/dev-util/astyle/ChangeLog
+++ b/dev-util/astyle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/astyle
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/ChangeLog,v 1.9 2004/06/25 02:19:41 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/ChangeLog,v 1.10 2004/09/26 23:17:46 sekretarz Exp $
+
+ 27 Sep 2004; Karol Wojtaszek <sekretarz@gentoo.org>
+ +files/astyle-gcc34.patch, astyle-1.15.3-r1.ebuild, astyle-1.15.3.ebuild:
+ Fixed gcc-3.4 compile issues. Thanks to Igor V. Kovalenko <garrison@mail.ru>
+ in Bug #63811
28 Mar 2004; David Holm <dholm@gentoo.org> astyle-1.15.3-r1.ebuild:
Added to ~ppc.
diff --git a/dev-util/astyle/astyle-1.15.3-r1.ebuild b/dev-util/astyle/astyle-1.15.3-r1.ebuild
index ebcc7e3c9482..7fb136afd615 100644
--- a/dev-util/astyle/astyle-1.15.3-r1.ebuild
+++ b/dev-util/astyle/astyle-1.15.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/astyle-1.15.3-r1.ebuild,v 1.4 2004/06/25 02:19:41 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/astyle-1.15.3-r1.ebuild,v 1.5 2004/09/26 23:17:46 sekretarz Exp $
inherit eutils
@@ -20,6 +20,9 @@ S=${WORKDIR}
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/cmd-line-fix.diff
+
+ #gcc-3.4 fix
+ epatch ${FILESDIR}/${PN}-gcc34.patch
}
src_compile() {
diff --git a/dev-util/astyle/astyle-1.15.3.ebuild b/dev-util/astyle/astyle-1.15.3.ebuild
index 535c933763bb..a3838ff70f12 100644
--- a/dev-util/astyle/astyle-1.15.3.ebuild
+++ b/dev-util/astyle/astyle-1.15.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/astyle-1.15.3.ebuild,v 1.12 2004/06/25 02:19:41 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/astyle-1.15.3.ebuild,v 1.13 2004/09/26 23:17:46 sekretarz Exp $
inherit eutils
@@ -20,6 +20,9 @@ S=${WORKDIR}
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/cmd-line-fix.diff
+
+ #gcc-3.4 fix
+ epatch ${FILESDIR}/${PN}-gcc34.patch
}
src_compile() {
diff --git a/dev-util/astyle/files/astyle-gcc34.patch b/dev-util/astyle/files/astyle-gcc34.patch
new file mode 100644
index 000000000000..50b7e8631cc4
--- /dev/null
+++ b/dev-util/astyle/files/astyle-gcc34.patch
@@ -0,0 +1,10 @@
+--- astyle_main.cpp~ 2004-05-01 18:42:25.026637744 +0400
++++ astyle_main.cpp 2004-05-01 18:45:39.716040456 +0400
+@@ -53,6 +53,7 @@
+
+ const string _version = "1.15.3";
+
++bool parseOption(ASFormatter &formatter, const string &arg, const string &errorInfo);
+
+ class ASStreamIterator :
+ public ASSourceIterator