summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2004-08-19 04:14:12 +0000
committerRob Cakebread <pythonhead@gentoo.org>2004-08-19 04:14:12 +0000
commita576dd819c32fb738bb5a76a31fe5c1cd05c468f (patch)
tree45c4ea7ca1f6d15936b5a3db7422559319f149d4 /dev-util/boa-constructor/boa-constructor-0.3.0_alpha.ebuild
parentFixed USE logic (Manifest recommit) (diff)
downloadgentoo-2-a576dd819c32fb738bb5a76a31fe5c1cd05c468f.tar.gz
gentoo-2-a576dd819c32fb738bb5a76a31fe5c1cd05c468f.tar.bz2
gentoo-2-a576dd819c32fb738bb5a76a31fe5c1cd05c468f.zip
Version bump. bug# 60825
Diffstat (limited to 'dev-util/boa-constructor/boa-constructor-0.3.0_alpha.ebuild')
-rw-r--r--dev-util/boa-constructor/boa-constructor-0.3.0_alpha.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-util/boa-constructor/boa-constructor-0.3.0_alpha.ebuild b/dev-util/boa-constructor/boa-constructor-0.3.0_alpha.ebuild
new file mode 100644
index 000000000000..70b99d75d063
--- /dev/null
+++ b/dev-util/boa-constructor/boa-constructor-0.3.0_alpha.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boa-constructor/boa-constructor-0.3.0_alpha.ebuild,v 1.1 2004/08/19 04:14:12 pythonhead Exp $
+
+BOA=${P/_alpha/}
+S=${WORKDIR}/${BOA}
+DESCRIPTION="Python GUI RAD development tool."
+HOMEPAGE="http://boa-constructor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/boa-constructor/${BOA}.src.zip"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~ppc"
+IUSE=""
+
+RDEPEND=">=dev-lang/python-2.0
+ >=dev-python/wxpython-2.4.2.4
+ dev-libs/expat"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_compile() {
+ python -c "import compileall; compileall.compile_dir('.', force=1)"
+}
+
+src_install () {
+ local pv=`python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:'`
+ local boadir="/usr/lib/python${pv}/site-packages/boa"
+
+ local dir
+ for dir in `find . -type d`
+ do
+ insinto "${boadir}/${dir}"
+ cd "${dir}"
+ local file
+ for file in *
+ do
+ [ -f "${file}" ] && doins "${file}"
+ done
+ cd "${S}"
+ done
+
+ insinto "${boadir}"
+ insinto "${boadir}/Plug-ins"
+ doins Plug-ins/*
+
+ dobin "${FILESDIR}/boa-constructor"
+
+ dodoc Bugs.txt Changes.txt Credits.txt README.txt
+}