summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2008-08-25 21:19:23 +0000
committerMarkus Ullmann <jokey@gentoo.org>2008-08-25 21:19:23 +0000
commit3ac0b920f3fc3451514670f1b21239f8a88fe356 (patch)
tree04194aacc72f3bdb1cdf3a1c26c11e1a5a00125f /dev-util/bugle
parentstable ppc64, bug 235719 (diff)
downloadgentoo-2-3ac0b920f3fc3451514670f1b21239f8a88fe356.tar.gz
gentoo-2-3ac0b920f3fc3451514670f1b21239f8a88fe356.tar.bz2
gentoo-2-3ac0b920f3fc3451514670f1b21239f8a88fe356.zip
Version bump wrt bug #235492 thanks to Dennis Schridde for the notification
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo i686)
Diffstat (limited to 'dev-util/bugle')
-rw-r--r--dev-util/bugle/ChangeLog8
-rw-r--r--dev-util/bugle/bugle-0.0.20080803.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-util/bugle/ChangeLog b/dev-util/bugle/ChangeLog
index f1913e9de2e5..e7d0e3857846 100644
--- a/dev-util/bugle/ChangeLog
+++ b/dev-util/bugle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/bugle
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bugle/ChangeLog,v 1.7 2008/08/10 13:08:26 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bugle/ChangeLog,v 1.8 2008/08/25 21:19:23 jokey Exp $
+
+*bugle-0.0.20080803 (25 Aug 2008)
+
+ 25 Aug 2008; Markus Ullmann <jokey@gentoo.org> +bugle-0.0.20080803.ebuild:
+ Version bump wrt bug #235492 thanks to Dennis Schridde for the
+ notification
*bugle-0.0.20080303 (10 Aug 2008)
diff --git a/dev-util/bugle/bugle-0.0.20080803.ebuild b/dev-util/bugle/bugle-0.0.20080803.ebuild
new file mode 100644
index 000000000000..fad310a6fbca
--- /dev/null
+++ b/dev-util/bugle/bugle-0.0.20080803.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bugle/bugle-0.0.20080803.ebuild,v 1.1 2008/08/25 21:19:23 jokey Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A tool for OpenGL debugging"
+HOMEPAGE="http://www.opengl.org/sdk/tools/BuGLe/"
+SRC_URI="mirror://sourceforge/bugle/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ffmpeg gtk readline"
+
+DEPEND="ffmpeg? ( media-video/ffmpeg )
+ gtk? ( >=x11-libs/gtk+-2.4.0 >=x11-libs/gtkglext-1.0.0 )
+ readline? ( sys-libs/readline )
+ virtual/opengl
+ sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ if [ "$(gcc-version)" == "4.0" ]; then
+ die "BuGLe doesn't work with gcc-4.0. Use gcc-3.x or >=gcc-4.1."
+ fi
+
+ econf \
+ $(use_with ffmpeg) \
+ $(use_with readline) \
+ $(use_with gtk) \
+ $(use_with gtk gtkglext) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodoc README TODO TROUBLESHOOTING FAQ doc/*.{txt,html}
+ docinto examples
+ dodoc doc/examples/*
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ elog "See man 3 bugle for an introduction to BuGLe."
+}