summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-01-10 13:30:46 +0000
committerPeter Volkov <pva@gentoo.org>2009-01-10 13:30:46 +0000
commitaf5cdd0812230bdcf0d48fc1e20f4696543d517f (patch)
tree1045b5ab1f2e44cc89429799baebe7ca7ede18b2 /dev-util/bzr/bzr-1.8.ebuild
parentClean old. (diff)
downloadgentoo-2-af5cdd0812230bdcf0d48fc1e20f4696543d517f.tar.gz
gentoo-2-af5cdd0812230bdcf0d48fc1e20f4696543d517f.tar.bz2
gentoo-2-af5cdd0812230bdcf0d48fc1e20f4696543d517f.zip
Version bump. Remove old.
(Portage version: 2.2_rc20/cvs/Linux 2.6.26-openvz.git-89451f9 i686)
Diffstat (limited to 'dev-util/bzr/bzr-1.8.ebuild')
-rw-r--r--dev-util/bzr/bzr-1.8.ebuild106
1 files changed, 0 insertions, 106 deletions
diff --git a/dev-util/bzr/bzr-1.8.ebuild b/dev-util/bzr/bzr-1.8.ebuild
deleted file mode 100644
index 9d5956dc205d..000000000000
--- a/dev-util/bzr/bzr-1.8.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/bzr-1.8.ebuild,v 1.2 2008/10/26 21:35:26 hawking Exp $
-
-NEED_PYTHON=2.4
-
-inherit distutils bash-completion elisp-common eutils versionator
-
-MY_PV=${PV/_rc/rc}
-MY_P=${PN}-${MY_PV}
-SERIES=$(get_version_component_range 1-2)
-
-DESCRIPTION="Bazaar is a next generation distributed version control system."
-HOMEPAGE="http://bazaar-vcs.org/"
-#SRC_URI="http://bazaar-vcs.org/releases/src/${MY_P}.tar.gz"
-SRC_URI="http://launchpad.net/bzr/${SERIES}/${MY_PV}/+download/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
-IUSE="curl emacs sftp test"
-
-RDEPEND="|| ( dev-python/celementtree >=dev-lang/python-2.5 )
- curl? ( dev-python/pycurl )
- sftp? ( dev-python/paramiko )"
-
-DEPEND="emacs? ( virtual/emacs )
- test? (
- $RDEPEND
- dev-python/medusa
- )"
-
-S="${WORKDIR}/${MY_P}"
-PYTHON_MODNAME="bzrlib"
-SITEFILE=71bzr-gentoo.el
-DOCS="doc/*.txt"
-
-src_unpack() {
- distutils_src_unpack
-
- # Don't regenerate .c files from .pyx when pyrex is found.
- epatch "${FILESDIR}/${PN}-1.8-no-pyrex.patch"
- # Don't run lock permission tests when running as root
- epatch "${FILESDIR}/${PN}-0.90-tests-fix_root.patch"
- # Fix permission errors when run under directories with setgid set.
- epatch "${FILESDIR}/${PN}-0.90-tests-sgid.patch"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use emacs; then
- elisp-compile contrib/emacs/bzr-mode.el || die "Emacs modules failed!"
- fi
-}
-
-src_install() {
- distutils_src_install --install-data /usr/share
-
- docinto developers
- dodoc doc/developers/*
- for doc in mini-tutorial tutorials user-{guide,reference}; do
- docinto $doc
- dodoc doc/en/$doc/*
- done
-
- if use emacs; then
- elisp-install ${PN} contrib/emacs/*.el* || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die "elisp-site-file-install failed"
-
- # don't add automatically to the load-path, so the sitefile
- # can do a conditional loading
- touch "${D}${SITELISP}/${PN}/.nosearch"
- fi
-
- insinto /usr/share/zsh/site-functions
- doins contrib/zsh/_bzr
- dobashcompletion contrib/bash/bzr
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- bash-completion_pkg_postinst
-
- if use emacs; then
- elisp-site-regen
- elog "If you are using a GNU Emacs version greater than 22.1, bzr support"
- elog "is already included. This ebuild does not automatically activate bzr support"
- elog "in versions below, but prepares it in a way you can load it from your ~/.emacs"
- elog "file by adding"
- elog " (load \"bzr-mode\")"
- fi
-}
-
-pkg_postrm() {
- distutils_pkg_postrm
- use emacs && elisp-site-regen
-}
-
-src_test() {
- # Some tests expect the usual pyc compiling behaviour.
- python_enable_pyc
- "${python}" bzr --no-plugins selftest || die "bzr selftest failed"
- # Just to make sure we don't hit any errors on later stages.
- python_disable_pyc
-}