summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2012-07-08 16:19:57 +0000
committerRaúl Porcel <armin76@gentoo.org>2012-07-08 16:19:57 +0000
commit82390ab811af2b3f29b50cacecfd610c12d592df (patch)
tree248f55a8361cfc8d5afdd9f00e7c97f030e699e0 /dev-util/catalyst
parentMarked ~hppa (bug #417573). (diff)
downloadgentoo-2-82390ab811af2b3f29b50cacecfd610c12d592df.tar.gz
gentoo-2-82390ab811af2b3f29b50cacecfd610c12d592df.tar.bz2
gentoo-2-82390ab811af2b3f29b50cacecfd610c12d592df.zip
2.0.9 can't be released yet, so i'm forced to add patches here
(Portage version: 2.1.11.5/cvs/Linux ia64, RepoMan options: --force)
Diffstat (limited to 'dev-util/catalyst')
-rw-r--r--dev-util/catalyst/ChangeLog8
-rw-r--r--dev-util/catalyst/catalyst-2.0.8.1-r2.ebuild103
-rw-r--r--dev-util/catalyst/files/2.0.8.1-arm-softfp.patch36
3 files changed, 146 insertions, 1 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index 1f1259e5bb34..da6964c637bc 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/catalyst
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.244 2012/05/15 16:54:08 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.245 2012/07/08 16:19:56 armin76 Exp $
+
+*catalyst-2.0.8.1-r2 (08 Jul 2012)
+
+ 08 Jul 2012; Raúl Porcel <armin76@gentoo.org>
+ +files/2.0.8.1-arm-softfp.patch, +catalyst-2.0.8.1-r2.ebuild:
+ 2.0.9 can't be released yet, so i'm forced to add patches here
*catalyst-2.0.8.1-r1 (15 May 2012)
diff --git a/dev-util/catalyst/catalyst-2.0.8.1-r2.ebuild b/dev-util/catalyst/catalyst-2.0.8.1-r2.ebuild
new file mode 100644
index 000000000000..815fe0713d3c
--- /dev/null
+++ b/dev-util/catalyst/catalyst-2.0.8.1-r2.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.8.1-r2.ebuild,v 1.1 2012/07/08 16:19:56 armin76 Exp $
+
+# catalyst-9999 -> latest Git
+# catalyst-2.9999 -> catalyst_2 branch from Git
+# catalyst-VER -> normal catalyst release
+
+EAPI=3
+PYTHON_DEPEND="2"
+
+if [[ ${PV} == 9999* || ${PV} == 2.9999* ]]; then
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/catalyst.git"
+ inherit git-2
+ SRC_URI=""
+ S="${WORKDIR}/${PN}"
+ KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2"
+ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+fi
+inherit eutils multilib python
+
+DESCRIPTION="release metatool used for creating releases based on Gentoo Linux"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst/"
+
+LICENSE="GPL-2"
+SLOT="0"
+RESTRICT=""
+IUSE="ccache kernel_linux"
+
+DEPEND="app-text/asciidoc"
+RDEPEND="app-crypt/shash
+ virtual/cdrtools
+ ccache? ( dev-util/ccache )
+ ia64? ( sys-fs/dosfstools )
+ kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
+
+pkg_setup() {
+ if use ccache ; then
+ einfo "Enabling ccache support for catalyst."
+ else
+ ewarn "By default, ccache support for catalyst is disabled."
+ ewarn "If this is not what you intended,"
+ ewarn "then you should add ccache to your USE."
+ fi
+ echo
+ einfo "The template spec files are now installed by default. You can find"
+ einfo "them under /usr/share/doc/${PF}/examples"
+ einfo "and they are considered to be the authorative source of information"
+ einfo "on catalyst."
+ echo
+ if [[ ${PV} == 9999* || ${PV} == 2.9999* ]]; then
+ ewarn "The ${EGIT_BRANCH:-master} branch (what you get with this ${PV} ebuild) contains"
+ ewarn "work-in-progress code. Be aware that it's likely that it will not"
+ ewarn "be in a working state at any given point. Please do not file bugs"
+ ewarn "until you have posted on the gentoo-catalyst mailing list and we"
+ ewarn "have asked you to do so."
+ fi
+ python_set_active_version 2
+}
+
+src_prepare() {
+ python_convert_shebangs 2 catalyst modules/catalyst_lock.py
+
+ epatch "${FILESDIR}"/${PV}-arm-softfp.patch
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/${PN}
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe catalyst || die "copying catalyst"
+ if [[ ${PV} == 9999* ]]; then
+ doins -r modules files || die "copying files"
+ else
+ doins -r arch modules livecd || die "copying files"
+ fi
+ for x in targets/*; do
+ exeinto /usr/$(get_libdir)/${PN}/$x
+ doexe $x/* || die "copying ${x}"
+ done
+ make_wrapper catalyst /usr/$(get_libdir)/${PN}/catalyst
+ insinto /etc/catalyst
+ doins files/catalyst.conf files/catalystrc || die "copying configuration"
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* || die
+ dodoc README ChangeLog AUTHORS
+ doman files/catalyst.1
+ # Here is where we actually enable ccache
+ use ccache && \
+ dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
+ /etc/catalyst/catalyst.conf
+ dosed "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
+ /etc/catalyst/catalyst.conf
+}
+
+pkg_postinst() {
+ einfo "You can find more information about catalyst by checking out the"
+ einfo "catalyst project page at:"
+ einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+ echo
+}
diff --git a/dev-util/catalyst/files/2.0.8.1-arm-softfp.patch b/dev-util/catalyst/files/2.0.8.1-arm-softfp.patch
new file mode 100644
index 000000000000..51ae1e718740
--- /dev/null
+++ b/dev-util/catalyst/files/2.0.8.1-arm-softfp.patch
@@ -0,0 +1,36 @@
+diff -ur catalyst-2.0.8.1.orig//arch/arm.py catalyst-2.0.8.1/arch/arm.py
+--- catalyst-2.0.8.1.orig//arch/arm.py 2012-07-07 20:28:46.788719269 +0200
++++ catalyst-2.0.8.1/arch/arm.py 2012-07-07 20:29:28.099721112 +0200
+@@ -67,28 +67,28 @@
+ "Builder class for armv6j target"
+ def __init__(self,myspec):
+ generic_arm.__init__(self,myspec)
+- self.settings["CHOST"]="armv6j-unknown-linux-gnueabi"
++ self.settings["CHOST"]="armv6j-softfp-linux-gnueabi"
+ self.settings["CFLAGS"]+=" -march=armv6j -mfpu=vfp -mfloat-abi=softfp"
+
+ class arch_armv6z(generic_arm):
+ "Builder class for armv6z target"
+ def __init__(self,myspec):
+ generic_arm.__init__(self,myspec)
+- self.settings["CHOST"]="armv6z-unknown-linux-gnueabi"
++ self.settings["CHOST"]="armv6z-softfp-linux-gnueabi"
+ self.settings["CFLAGS"]+=" -march=armv6z -mfpu=vfp -mfloat-abi=softfp"
+
+ class arch_armv6zk(generic_arm):
+ "Builder class for armv6zk target"
+ def __init__(self,myspec):
+ generic_arm.__init__(self,myspec)
+- self.settings["CHOST"]="armv6zk-unknown-linux-gnueabi"
++ self.settings["CHOST"]="armv6zk-softfp-linux-gnueabi"
+ self.settings["CFLAGS"]+=" -march=armv6zk -mfpu=vfp -mfloat-abi=softfp"
+
+ class arch_armv7a(generic_arm):
+ "Builder class for armv7a target"
+ def __init__(self,myspec):
+ generic_arm.__init__(self,myspec)
+- self.settings["CHOST"]="armv7a-unknown-linux-gnueabi"
++ self.settings["CHOST"]="armv7a-softfp-linux-gnueabi"
+ self.settings["CFLAGS"]+=" -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp"
+
+ class arch_armv6j_hardfp(generic_arm): \ No newline at end of file